summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 4 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa31b14b05a9..284b8f0b4068 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nsz-git
pkgdesc = Switch Homebrew compatible NSP/XCI compressor/decompressor
pkgver = 3.1.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/nicoboss/nsz
arch = any
license = MIT
@@ -16,9 +16,7 @@ pkgbase = nsz-git
provides = nsz=3.1.1
conflicts = nsz
source = nsz-git::git+https://github.com/nicoboss/nsz.git
- source = 0001-Fix-master-key-name-format.patch
sha256sums = SKIP
- sha256sums = 4f8f0b859cc698b3b856a3cd4ea102e87a4e9c13685767b39cbbfb862fd3f72f
pkgname = nsz-git
diff --git a/PKGBUILD b/PKGBUILD
index cf37c3de3b73..f530dad20940 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Armbruster <michael at armbrust dot me>
pkgname=nsz-git
-pkgrel=5
+pkgrel=6
pkgver=3.1.1
pkgdesc='Switch Homebrew compatible NSP/XCI compressor/decompressor'
conflicts=("${pkgname%-*}")
@@ -12,20 +12,14 @@ license=('MIT')
depends=('python>=3.6' 'python-pycryptodome>=3.9.0' 'python-zstandard' 'python-enlighten')
optdepends=('python-pygame' 'python-kivy==1.11.1')
makedepends=('git' 'python-setuptools')
-source=("${pkgname}::git+https://github.com/nicoboss/${pkgname%-*}.git"
- '0001-Fix-master-key-name-format.patch')
-sha256sums=('SKIP'
- '4f8f0b859cc698b3b856a3cd4ea102e87a4e9c13685767b39cbbfb862fd3f72f')
+source=("${pkgname}::git+https://github.com/nicoboss/${pkgname%-*}.git")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- patch -d "${pkgname}" -Np1 -i "${srcdir}/0001-Fix-master-key-name-format.patch"
-}
-
build() {
cd "${pkgname}"
python setup.py build