summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7dfee402911
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ntf
+ pkgdesc = Brings notification to your shell
+ pkgver = v1.0.1.r3.gd52a786
+ pkgrel = 1
+ url = https://github.com/hrntknr/ntf
+ arch = any
+ license = GPL3
+ makedepends = go
+ provides = ntf-git
+ source = git+https://github.com/hrntknr/ntf.git
+ sha256sums = SKIP
+
+pkgname = ntf-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc6febc420a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Robin Ekman < robin.seth.ekman [at] gmail [dot] com >
+
+pkgbase=ntf
+pkgname=${pkgbase}-git
+pkgver=v1.0.1.r3.gd52a786
+pkgrel=1
+pkgdesc="Brings notification to your shell"
+url='https://github.com/hrntknr/ntf'
+arch=('any')
+license=('GPL3')
+depends=()
+makedepends=(
+ 'go'
+)
+source=(
+ 'git+https://github.com/hrntknr/ntf.git'
+)
+sha256sums=(
+ 'SKIP'
+)
+
+provides=("${pkgname}")
+
+pkgver() {
+ cd "${pkgbase}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgbase}"
+
+ go build -ldflags "-s -w"
+}
+
+package() {
+ cd "${pkgbase}"
+
+ install -Dm755 -t "${pkgdir}/usr/bin" ./ntf
+}