summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b9a9c53e979..7ce10562a47f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = nvfancontrol-git
license = GPL3
makedepends = cargo
makedepends = libxnvctrl
+ depends = gcc-libs
depends = libxext
optdepends = nvidia: For GTX 4xx or newer cards
optdepends = nvidia-340xx: For G8x, G9x and GTX 2xx cards
diff --git a/PKGBUILD b/PKGBUILD
index 939f648ca753..f72ffbde1078 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: katt <magunasu.b97@gmail.com>
+# Maintainer: Artem Klevtsov <a.a.klevtsov@gmail.com>
_pkgname=nvfancontrol
pkgname=$_pkgname-git
@@ -8,25 +9,25 @@ pkgdesc="NVidia dynamic fan control"
arch=('i686' 'x86_64')
url="https://github.com/foucault/nvfancontrol"
license=('GPL3')
-depends=('libxext')
+depends=('gcc-libs' 'libxext')
makedepends=('cargo' 'libxnvctrl')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
optdepends=('nvidia: For GTX 4xx or newer cards'
'nvidia-340xx: For G8x, G9x and GTX 2xx cards')
-source=("$pkgname::git+$url")
+source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "${pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
+ cd "${pkgname}"
cargo build --release
}
package() {
- install -Dm755 "$pkgname/target/release/$_pkgname" -t "$pkgdir/usr/bin"
+ install -Dm755 "${pkgname}/target/release/${_pkgname}" -t "${pkgdir}/usr/bin"
}