summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f71e8f6f8f11..14bee6ff3cad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,11 +4,12 @@ pkgbase = obquit-git
pkgrel = 1
url = https://github.com/dglava/obquit
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
makedepends = python-setuptools
makedepends = python-installer
makedepends = python-build
+ makedepends = python-wheel
depends = python
depends = python-gobject
depends = python-cairo
diff --git a/PKGBUILD b/PKGBUILD
index 49def70f19ae..8a99c03c07af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,16 @@ pkgrel=1
pkgdesc="Shutdown/reboot/logout utility script"
arch=('any')
url="https://github.com/dglava/obquit"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('python' 'python-gobject' 'python-cairo' 'gtk3')
-makedepends=('git' 'python-setuptools' 'python-installer' 'python-build')
+makedepends=('git' 'python-setuptools' 'python-installer' 'python-build'
+ 'python-wheel')
source=('git+https://github.com/dglava/obquit.git')
md5sums=('SKIP')
build() {
cd "$srcdir/${pkgname%-git}"
- python -m build
+ python -m build --wheel --no-isolation
}
package() {