summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--0001-Add-installation-of-locale-files.patch23
-rw-r--r--0002-add-pt-BR-translation.patch27
-rw-r--r--PKGBUILD43
5 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6f9841adeb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = obs-plugin-time-source
+ pkgdesc = Shows date and time in OBS as a source
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://git.sr.ht/~krystianch/obs-time-source
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ depends = obs-studio
+ source = https://git.sr.ht/~krystianch/obs-time-source/archive/v0.1.tar.gz
+ source = 0001-Add-installation-of-locale-files.patch
+ source = 0002-add-pt-BR-translation.patch
+ b2sums = 8dc59e22c93e8aabd907b4bb2e94b8f09e8e6a4c56ed26698c767868a34394d5955cb0100248fd18ec402a7409d13a29e6d9de463f159f756faf1b95ba1536d6
+ b2sums = f11e5fc225290a1db79a4295c2ebce83b868f43f435f5f2d904f81171bfdb0839080bd0ef0942c29c7db69d621ec6f3fd6ef602b638b2f9f4796910b1edecce7
+ b2sums = f3c38c6be272b233743cea39e47a7aeeb7f63bc73ee4aca1dcd688ba0f6eef359b696a1462587fc7279e9333694111611c2efc7e23a22469c39f0c5f779776e6
+
+pkgname = obs-plugin-time-source
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b7c4167c8c97
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.tar.gz
+src
+pkg
diff --git a/0001-Add-installation-of-locale-files.patch b/0001-Add-installation-of-locale-files.patch
new file mode 100644
index 000000000000..ed0f7350ea5c
--- /dev/null
+++ b/0001-Add-installation-of-locale-files.patch
@@ -0,0 +1,23 @@
+From 4bc3b3a62b118f71ff768206b93a1611e7176b2b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Krystian=20Chachu=C5=82a?= <krystian@krystianch.com>
+Date: Wed, 6 Sep 2023 23:45:40 +0200
+Subject: [PATCH 1/2] Add installation of locale files
+
+---
+ meson.build | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/meson.build b/meson.build
+index 25ba65d..825046a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -9,3 +9,6 @@ deps = [
+ shared_library('time-source', 'time-source.c', dependencies : deps,
+ install : true, install_dir : get_option('libdir') / 'obs-plugins',
+ name_prefix : '')
++
++install_subdir('data/locale',
++ install_dir : get_option('datadir') / 'obs/obs-plugins/time-source')
+--
+2.42.0
+
diff --git a/0002-add-pt-BR-translation.patch b/0002-add-pt-BR-translation.patch
new file mode 100644
index 000000000000..cc8ce6a5c4be
--- /dev/null
+++ b/0002-add-pt-BR-translation.patch
@@ -0,0 +1,27 @@
+From d1483f353f37d261176bd467110f8c434741111b Mon Sep 17 00:00:00 2001
+From: Joao Eriberto Mota Filho <eriberto@debian.org>
+Date: Tue, 19 Sep 2023 21:36:57 +0200
+Subject: [PATCH 2/2] add pt-BR translation
+
+---
+ data/locale/pt-BR.ini | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+ create mode 100644 data/locale/pt-BR.ini
+
+diff --git a/data/locale/pt-BR.ini b/data/locale/pt-BR.ini
+new file mode 100644
+index 0000000..bbd83f4
+--- /dev/null
++++ b/data/locale/pt-BR.ini
+@@ -0,0 +1,8 @@
++TimeSource="Data e Hora"
++TimeSource.Format="Formato"
++TimeSource.FormatDesc="EspecificaĆ§Ć£o de formato, de acordo com o strftime"
++TimeSource.Font="Fonte"
++TimeSource.BackgroundColor="Cor de Fundo"
++TimeSource.ForegroundColor="Cor de Frente"
++TimeSource.OutlineColor="Cor de Contorno"
++TimeSource.OutlineWidth="Largura do Contorno"
+--
+2.42.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cf243664361
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+
+pkgname=obs-plugin-time-source
+pkgver=0.1
+pkgrel=1
+pkgdesc="Shows date and time in OBS as a source"
+arch=('x86_64')
+url="https://git.sr.ht/~krystianch/obs-time-source"
+license=('GPL3')
+depends=('obs-studio')
+makedepends=('meson' 'ninja')
+source=("${url}/archive/v${pkgver}.tar.gz"
+ 0001-Add-installation-of-locale-files.patch
+ 0002-add-pt-BR-translation.patch)
+b2sums=('8dc59e22c93e8aabd907b4bb2e94b8f09e8e6a4c56ed26698c767868a34394d5955cb0100248fd18ec402a7409d13a29e6d9de463f159f756faf1b95ba1536d6'
+ 'f11e5fc225290a1db79a4295c2ebce83b868f43f435f5f2d904f81171bfdb0839080bd0ef0942c29c7db69d621ec6f3fd6ef602b638b2f9f4796910b1edecce7'
+ 'f3c38c6be272b233743cea39e47a7aeeb7f63bc73ee4aca1dcd688ba0f6eef359b696a1462587fc7279e9333694111611c2efc7e23a22469c39f0c5f779776e6')
+
+prepare() {
+ cd "${srcdir}/obs-time-source-v${pkgver}"
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
+
+ meson setup --prefix=/usr --buildtype=plain build
+}
+
+build() {
+ cd "${srcdir}/obs-time-source-v${pkgver}/build"
+
+ ninja
+}
+
+package() {
+ cd "${srcdir}/obs-time-source-v${pkgver}/build"
+
+ meson install --destdir "${pkgdir}"
+}