summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c207bc141239..1f536fd68900 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = obs-source-record
pkgdesc = Plugin for OBS Studio to add a filter that allows you to record a source
- pkgver = 0.3.2
- pkgrel = 2
+ pkgver = 0.3.4
+ pkgrel = 1
url = https://obsproject.com/forum/resources/source-record.1285/
arch = x86_64
arch = aarch64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = cmake
makedepends = git
depends = obs-studio>=29
options = debug
- source = obs-source-record::git+https://github.com/exeldro/obs-source-record#commit=4e27c040031831f9e9959f4947a6904ebe0fa23a
+ source = obs-source-record::git+https://github.com/exeldro/obs-source-record#commit=3c42da3785704d68ef800ac1d8f4b3fb890548e2
sha256sums = SKIP
pkgname = obs-source-record
diff --git a/PKGBUILD b/PKGBUILD
index 432befca788e..900d9c039a0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=obs-source-record
-pkgver=0.3.2
-pkgrel=2
+pkgver=0.3.4
+pkgrel=1
pkgdesc="Plugin for OBS Studio to add a filter that allows you to record a source"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/source-record.1285/"
-license=("GPL2")
+license=("GPL-2.0-or-later")
depends=("obs-studio>=29")
makedepends=("cmake" "git")
options=("debug")
-source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=4e27c040031831f9e9959f4947a6904ebe0fa23a")
+source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=3c42da3785704d68ef800ac1d8f4b3fb890548e2")
sha256sums=("SKIP")
build() {
@@ -20,7 +20,8 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
-DQT_VERSION=6 \
- -DCMAKE_C_FLAGS="-Wno-error=deprecated-declarations"
+ -DCMAKE_C_FLAGS="-Wno-error=deprecated-declarations" \
+ -Wno-dev
cmake --build build
}