summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 089e8611b759..62be9c505235 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,22 @@
pkgbase = ocaml-oasis
pkgdesc = Architecture for building OCaml libraries and applications.
- pkgver = 0.4.5
+ pkgver = 0.4.8
pkgrel = 1
url = http://oasis.forge.ocamlcore.org
arch = i686
arch = x86_64
license = LGPL
makedepends = ocaml
- makedepends = ocaml-batteries
+ makedepends = ocamlbuild
makedepends = ocaml-fileutils>=0.4.2
makedepends = ocaml-findlib
- makedepends = ocaml-ocamlgraph
makedepends = ocaml-ocamlify
- makedepends = ocaml-odn>=0.0.11
- makedepends = ocaml-ounit
makedepends = ocaml-ocamlmod
- makedepends = ocaml-pcre
- makedepends = ocaml-expect>=0.0.3
depends = glibc
depends = pcre
options = !strip
- source = http://forge.ocamlcore.org/frs/download.php/1475/oasis-0.4.5.tar.gz
- sha512sums = 97d5401762ffda6bf4d7a239d9c77f8647d58da1728925e6de6e8fdfded6f8e7bb69652a838b86ab7203cd68436b06f76921c76840b97db56a94bb87d74450d7
+ source = http://forge.ocamlcore.org/frs/download.php/1669/oasis-0.4.8.tar.gz
+ sha512sums = e0baf0f048647c25eac5472db0d2a22d0fcaf85fe61ebd88ec5a101c20d4916ecfa9d10fae069ba4479abb22b90c44f18312b9252727a8c7c7de4aa2d8d72663
pkgname = ocaml-oasis
diff --git a/PKGBUILD b/PKGBUILD
index b5bddaa2148a..5a84a39b1727 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,32 @@
# Contributor: Magnus Therning <magnus@therning.org>
pkgname=ocaml-oasis
-pkgver=0.4.5
+pkgver=0.4.8
pkgrel=1
pkgdesc='Architecture for building OCaml libraries and applications.'
arch=('i686' 'x86_64')
-url=("http://oasis.forge.ocamlcore.org")
+url="http://oasis.forge.ocamlcore.org"
license=('LGPL')
depends=('glibc' 'pcre')
makedepends=('ocaml'
- 'ocaml-batteries'
+ 'ocamlbuild'
'ocaml-fileutils>=0.4.2'
'ocaml-findlib'
- 'ocaml-ocamlgraph'
'ocaml-ocamlify'
- 'ocaml-odn>=0.0.11'
- 'ocaml-ounit'
- 'ocaml-ocamlmod'
- 'ocaml-pcre'
- 'ocaml-expect>=0.0.3')
-source=("http://forge.ocamlcore.org/frs/download.php/1475/oasis-${pkgver}.tar.gz")
-sha512sums=('97d5401762ffda6bf4d7a239d9c77f8647d58da1728925e6de6e8fdfded6f8e7bb69652a838b86ab7203cd68436b06f76921c76840b97db56a94bb87d74450d7')
+ 'ocaml-ocamlmod')
+source=("http://forge.ocamlcore.org/frs/download.php/1669/oasis-${pkgver}.tar.gz")
+sha512sums=('e0baf0f048647c25eac5472db0d2a22d0fcaf85fe61ebd88ec5a101c20d4916ecfa9d10fae069ba4479abb22b90c44f18312b9252727a8c7c7de4aa2d8d72663')
options=(!strip)
build() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
- make CONFIGUREFLAGS="--prefix /usr --destdir $pkgdir --disable-tests" build
+ ocaml setup.ml -configure --prefix "$pkgdir" --exec-prefix "$pkgdir/usr"
+ ocaml setup.ml -build
}
package() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
install -dm755 "$OCAMLFIND_DESTDIR"
- make install
+ ocaml setup.ml -install
}