summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f46d22a3b8ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ocaml-uuidm
+ pkgdesc = Universally unique identifiers (UUIDs) for OCaml
+ pkgver = 0.9.8
+ pkgrel = 1
+ url = https://erratique.ch/software/uuidm
+ arch = x86_64
+ license = ISC
+ makedepends = ocaml-topkg
+ makedepends = ocaml-findlib
+ makedepends = ocamlbuild
+ makedepends = opam
+ depends = ocaml>=4.08
+ depends = ocaml-cmdliner>=1.1.0
+ options = !strip
+ source = uuidm-0.9.8.tar.gz::https://github.com/dbuenzli/uuidm/archive/v0.9.8.tar.gz
+ sha256sums = D9D24AF1BFCD3A9B1189DF10BF937688EF00279A72F024A410AA44C32A3D95CC
+
+pkgname = ocaml-uuidm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeac13861fd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dringsim <dringsim@qq.com>
+
+pkgname=ocaml-uuidm
+_pkgname=${pkgname#ocaml-}
+pkgver=0.9.8
+pkgrel=1
+pkgdesc='Universally unique identifiers (UUIDs) for OCaml'
+arch=('x86_64')
+url=https://erratique.ch/software/uuidm
+license=('ISC')
+options=('!strip')
+depends=('ocaml>=4.08' 'ocaml-cmdliner>=1.1.0')
+makedepends=('ocaml-topkg' 'ocaml-findlib' 'ocamlbuild' 'opam')
+source=("${_pkgname}-$pkgver.tar.gz::https://github.com/dbuenzli/${_pkgname}/archive/v$pkgver.tar.gz")
+sha256sums=('D9D24AF1BFCD3A9B1189DF10BF937688EF00279A72F024A410AA44C32A3D95CC')
+
+build() {
+ cd ${_pkgname}-$pkgver
+ ocaml pkg/pkg.ml build --with-cmdliner true
+}
+
+package() {
+ cd ${_pkgname}-$pkgver
+
+ opam-installer --prefix="${pkgdir}/usr" \
+ --libdir="${pkgdir}$(ocamlc -where)" \
+ --docdir="${pkgdir}/usr/share/doc" \
+ --stubsdir="${pkgdir}$(ocamlc -where)/stublibs" \
+ ./uuidm.install
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE.md
+}