summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3adba512232a..d4262e236fbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = ocaml-xmlplaylist
pkgdesc = OCaml module to parse various RSS playlist formats
- pkgver = 0.1.4
+ pkgver = 0.1.5
pkgrel = 1
url = https://github.com/savonet/ocaml-xmlplaylist
arch = i686
arch = x86_64
license = LGPL2.1
+ makedepends = dune
makedepends = ocaml-findlib
depends = ocaml
depends = ocaml-xmlm
options = !strip
- source = https://github.com/savonet/ocaml-xmlplaylist/archive/refs/tags/v0.1.4.tar.gz
- sha256sums = 99117433dacb84117af7f01bac67df81
+ source = https://github.com/savonet/ocaml-xmlplaylist/archive/refs/tags/v0.1.5.tar.gz
+ sha256sums = 07c26aefbb36a0fd6295e40b2f41a900442ec24614a834e84cb8163c4bd54d46
pkgname = ocaml-xmlplaylist
diff --git a/PKGBUILD b/PKGBUILD
index 1126e4200fec..9436d0919892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-xmlplaylist
-pkgver=0.1.4 # renovate: datasource=github-tags depName=savonet/ocaml-xmlplaylist
+pkgver=0.1.5 # renovate: datasource=github-tags depName=savonet/ocaml-xmlplaylist
pkgrel=1
pkgdesc="OCaml module to parse various RSS playlist formats"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-xmlplaylist"
license=('LGPL2.1')
depends=('ocaml' 'ocaml-xmlm')
-makedepends=('ocaml-findlib')
+makedepends=('dune' 'ocaml-findlib')
options=('!strip')
source=("https://github.com/savonet/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('99117433dacb84117af7f01bac67df81')
+sha256sums=('07c26aefbb36a0fd6295e40b2f41a900442ec24614a834e84cb8163c4bd54d46')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure
- make
+ dune build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}"
- make install
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "/usr/lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}