summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8069d7f23e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ocaml4-ocamlbuild
+ pkgdesc = Build tool, that has built-in rules for building OCaml library and programs
+ pkgver = 0.14.2
+ pkgrel = 1
+ url = https://github.com/ocaml/ocamlbuild
+ arch = x86_64
+ license = GPL2
+ depends = ocaml4
+ options = !makeflags
+ source = ocamlbuild-0.14.2.tar.gz::https://github.com/ocaml/ocamlbuild/archive/0.14.2.tar.gz
+ b2sums = d81613878f93f27c6de41461e6b3cebe0744a5204297725263a608cb129a708aaf6f27b444b97d68f2bde844a760f8e78647641f10eed61e727ef3936562cdea
+
+pkgname = ocaml4-ocamlbuild
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..382d867feb8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Jürgen Hötzel <juergen@hoetzel.info>
+
+pkgname=ocaml4-ocamlbuild
+pkgver=0.14.2
+pkgrel=1
+pkgdesc='Build tool, that has built-in rules for building OCaml library and programs'
+arch=(x86_64)
+url='https://github.com/ocaml/ocamlbuild'
+license=(GPL2)
+depends=(ocaml4)
+options=(!makeflags)
+source=("ocamlbuild-$pkgver.tar.gz::https://github.com/ocaml/ocamlbuild/archive/$pkgver.tar.gz")
+b2sums=('d81613878f93f27c6de41461e6b3cebe0744a5204297725263a608cb129a708aaf6f27b444b97d68f2bde844a760f8e78647641f10eed61e727ef3936562cdea')
+
+build() {
+ cd "ocamlbuild-$pkgver"
+ make configure PREFIX=/usr MANDIR=/usr/share/man
+ make
+}
+
+package() {
+ cd "ocamlbuild-$pkgver"
+ make DESTDIR="$pkgdir" install
+}