summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD24
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5327129ab57d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = occi-cli
+ pkgdesc = This gem is a client implementation of the Open Cloud Computing Interface in Ruby
+ pkgver = 4.3.10
+ pkgrel = 1
+ url = http://egi-fctf.github.io/rOCCI-cli/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = ruby>=1.9.3
+ depends = ruby-activesupport>=4.0.0
+ depends = ruby-activesupport<5
+ depends = ruby-highline>=1.6.21
+ depends = ruby-highline<2
+ depends = ruby-json>=1.8.1
+ depends = ruby-json<3
+ depends = occi-api>=4.3.14
+ depends = occi-api<5
+ noextract = occi-cli-4.3.10.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/occi-cli-4.3.10.gem
+ sha256sums = 8d7c20c5db39a0c794be8e2f022da501b84d799dc906dc5803ff1058d7cdc6fe
+
+pkgname = occi-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d085398182b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer Roberto Valentini <valantin89 [at] gmail [dot] com>
+
+pkgname=occi-cli
+pkgver=4.3.10
+pkgrel=1
+pkgdesc='This gem is a client implementation of the Open Cloud Computing Interface in Ruby'
+arch=(i686 x86_64)
+url='http://egi-fctf.github.io/rOCCI-cli/'
+license=(Apache)
+depends=('ruby>=1.9.3'
+ 'ruby-activesupport>=4.0.0' 'ruby-activesupport<5'
+ 'ruby-highline>=1.6.21' 'ruby-highline<2'
+ 'ruby-json>=1.8.1' 'ruby-json<3'
+ 'occi-api>=4.3.14' 'occi-api<5')
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/${pkgname}-${pkgver}.gem")
+noextract=($pkgname-$pkgver.gem)
+sha256sums=('8d7c20c5db39a0c794be8e2f022da501b84d799dc906dc5803ff1058d7cdc6fe')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install --no-document -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" $pkgname-$pkgver.gem
+ rm "${pkgdir}/${_gemdir}/cache/${pkgname}-${pkgver}.gem"
+}