summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30550bc27799
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Jan 22 23:24:30 UTC 2016
+pkgbase = ocilib
+ pkgdesc = OCILIB (C and C++ Driver for Oracle)
+ pkgver = 4.2.0
+ pkgrel = 1
+ url = https://github.com/vrogier/ocilib
+ arch = i686
+ arch = x86_64
+ license = GNU LESSER GENERAL PUBLIC LICENSE Version 2.1
+ depends = oracle-instantclient-sdk
+ source = https://github.com/vrogier/ocilib/releases/download/v4.2.0/ocilib-4.2.0-gnu.tar.gz
+ md5sums = 2705be616149b68419e27dafec0d7010
+
+pkgname = ocilib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7e891bb2173
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: <craven@gmx.net>
+# Former Maintainer: Milos Negovanovic <milos.negovanovic@gmail.com>
+
+pkgname=ocilib
+pkgver=4.2.0
+pkgrel=1
+pkgdesc='OCILIB (C and C++ Driver for Oracle)'
+arch=('i686' 'x86_64')
+url='https://github.com/vrogier/ocilib'
+license=('LGPL2')
+source=("https://github.com/vrogier/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}-gnu.tar.gz")
+md5sums=('2705be616149b68419e27dafec0d7010')
+depends=(oracle-instantclient-sdk)
+
+build() {
+ if ! env | grep -q ^ORACLE_HOME=
+ then
+ echo ORACLE_HOME is not exported. Make sure you installed the Oracle libraries correctly.
+ exit 1
+ fi
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --with-oracle-headers-path=/usr/include --with-oracle-lib-path=/usr/lib
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+