summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87c738c20076..d8d8a69cfa33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = octave-informationtheory
- pkgdesc = Functions and routines for basic Information Theory definitions, and source coding.
+ pkgdesc = Functions and routines for basic Information Theory definitions, and source coding
pkgver = 0.1.8
pkgrel = 3
- url = http://octave.sourceforge.net/informationtheory/
+ url = https://octave.sourceforge.io/informationtheory
install = octave-informationtheory.install
arch = any
groups = octave-forge
license = GPL
depends = octave>=2.9.7
noextract = informationtheory-0.1.8.tar.gz
- source = http://downloads.sourceforge.net/octave/informationtheory-0.1.8.tar.gz
- md5sums = 8948c888555cd4377edcc3cdc8611bee
+ source = https://downloads.sourceforge.net/octave/informationtheory-0.1.8.tar.gz
+ sha512sums = 14878e3e3f6c5b3ef43e2e7addd09bfc48ab6e4fc022b80448851c3f714fe0086144b740a08b0c445e9a3df65256ce8983d39cdd79f371339f419fc893a3ae69
pkgname = octave-informationtheory
-
diff --git a/PKGBUILD b/PKGBUILD
index f24e1d192531..ad7610cde775 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
#
+
_pack=informationtheory
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=0.1.8
pkgrel=3
-pkgdesc="Functions and routines for basic Information Theory definitions, and source coding."
+pkgdesc="Functions and routines for basic Information Theory definitions, and source coding"
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL')
groups=('octave-forge')
depends=('octave>=2.9.7')
@@ -20,11 +22,11 @@ makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('8948c888555cd4377edcc3cdc8611bee')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('14878e3e3f6c5b3ef43e2e7addd09bfc48ab6e4fc022b80448851c3f714fe0086144b740a08b0c445e9a3df65256ce8983d39cdd79f371339f419fc893a3ae69')
_octave_run() {
octave --no-history --no-init-file --no-window-system -q -f --eval "$*"