summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD49
2 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23b932570882..3b37ee15bd10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Dec 29 06:09:32 UTC 2016
pkgbase = octave-plot
pkgdesc = Additional ploting tools for Octave.
pkgver = 1.1.0
pkgrel = 5
- url = http://octave.sourceforge.net/plot/
+ url = https://octave.sourceforge.io/plot
install = octave-plot.install
arch = any
groups = octave-forge
license = GPL
depends = octave>=3.2
noextract = plot-1.1.0.tar.gz
- source = http://downloads.sourceforge.net/octave/plot-1.1.0.tar.gz
- md5sums = 2e75d4c9d880bf82e851963218bee96d
+ source = https://downloads.sourceforge.net/octave/plot-1.1.0.tar.gz
+ sha512sums = 168e0856b4284aeb8048174329836e43ea942be5381096f45d34f6c0e7a627f962e1548af394d96fa54ad93321ebb074ad155bb03b3085bed658fd3974c0185d
pkgname = octave-plot
-
diff --git a/PKGBUILD b/PKGBUILD
index 250ff39c7ed8..743155e331b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -7,12 +9,12 @@
#
_pack=plot
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=1.1.0
pkgrel=5
pkgdesc="Additional ploting tools for Octave."
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL')
groups=('octave-forge')
depends=('octave>=3.2')
@@ -20,39 +22,40 @@ makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('2e75d4c9d880bf82e851963218bee96d')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('168e0856b4284aeb8048174329836e43ea942be5381096f45d34f6c0e7a627f962e1548af394d96fa54ad93321ebb074ad155bb03b3085bed658fd3974c0185d')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps -noauto $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}