summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD35
2 files changed, 24 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 589936d98e05..2a59fa0a5889 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = ognibuild
pkgrel = 1
url = https://github.com/jelmer/ognibuild
arch = any
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
diff --git a/PKGBUILD b/PKGBUILD
index e3f13c2766e0..97e0db00b6d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,31 @@ pkgdesc="Detect and invoke build systems"
arch=('any')
#url="https://jelmer.uk/code/ognibuild"
url="https://github.com/jelmer/ognibuild"
-license=('GPL2')
-depends=('breezy' 'python-buildlog-consultant' 'python-requirements-parser'
- 'python-ruamel-yaml' 'python-setuptools' 'python-toml')
-makedepends=('python-build' 'python-installer' 'python-wheel')
-optdepends=('python-aiohttp-openmetrics'
- 'python-apt'
-# 'python-brz-debian'
- 'python-debian'
- 'python-debmutate'
- 'python-lz4'
- 'python-psycopg2')
+license=('GPL-2.0-or-later')
+depends=(
+ 'breezy'
+ 'python-buildlog-consultant'
+ 'python-requirements-parser'
+ 'python-ruamel-yaml'
+ 'python-setuptools'
+ 'python-toml'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+)
+optdepends=(
+ 'python-aiohttp-openmetrics'
+ 'python-apt'
+# 'python-brz-debian'
+ 'python-debian'
+ 'python-debmutate'
+ 'python-lz4'
+ 'python-psycopg2'
+)
source=("$pkgname-$pkgver.tar.gz::https://github.com/jelmer/ognibuild/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('04a167e20322387d5af077b66c76837a5491a1e21e77931566302e2067ed3080')
-#validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk> (expired)
build() {
cd "$pkgname-$pkgver"