summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82daab0a1a85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = omegat-plugin-epwing
+ pkgdesc = EPWING dictionary plugin for OmegaT
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = https://github.com/miurahr/omegat-plugin-epwing/
+ arch = any
+ license = GPL3
+ depends = omegat
+ options = !strip
+ source = https://github.com/miurahr/omegat-plugin-epwing/releases/download/v2.2.1/omegat-plugin-epwing-2.2.1.zip
+ sha256sums = 38dc8745b1a3eae3c464cc762ea231bf29b25c89650ff7048793a851f4d32f03
+
+pkgname = omegat-plugin-epwing
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe84cd27c868
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Hiroshi Miura <miurahr[at]northside[dat]tokyo>
+
+pkgname=omegat-plugin-epwing
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="EPWING dictionary plugin for OmegaT"
+arch=('any')
+url="https://github.com/miurahr/${pkgname}/"
+license=('GPL3')
+depends=('omegat')
+options=('!strip')
+source=("https://github.com/miurahr/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.zip")
+sha256sums=('38dc8745b1a3eae3c464cc762ea231bf29b25c89650ff7048793a851f4d32f03')
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}"/usr/share/java/omegat/plugins/epwing
+ cp -a "${pkgname}-${pkgver}"/* "${pkgdir}"/usr/share/java/omegat/plugins/epwing
+}