summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7c76a601d29..50937b2d5ce1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = ondir-git
- pkgdesc = a small program to automate tasks specific to certain directories
+ pkgdesc = Small program to automate tasks specific to certain directories
pkgver = r13.55279f0
- pkgrel = 1
- url = https://github.com/alecthomas/ondir.git
+ pkgrel = 2
+ url = https://github.com/alecthomas/ondir
arch = i686
arch = x86_64
license = GPL2
makedepends = git
depends = glibc
- provides = ondir-git
- conflicts = ondir-git
- source = ondir-git::git://github.com/alecthomas/ondir.git
+ source = git+https://github.com/alecthomas/ondir.git
md5sums = SKIP
pkgname = ondir-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4b875e230219..f220f9b8cb55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
-# Maintainer: Akhil J <akhil.j@outlook.in>
+# Maintainer: aulonsal <seraur at aulonsal dot com>
+# Contributor: Akhil J <akhil.j@outlook.in>
pkgname=ondir-git
+_pkgname="${pkgname%-git}"
pkgver=r13.55279f0
-pkgrel=1
-pkgdesc="a small program to automate tasks specific to certain directories"
+pkgrel=2
+pkgdesc="Small program to automate tasks specific to certain directories"
arch=('i686' 'x86_64')
-url="https://github.com/alecthomas/ondir.git"
+url="https://github.com/alecthomas/ondir"
license=('GPL2')
-makedepends=('git')
depends=('glibc')
-provides=("$pkgname")
-conflicts=("$pkgname")
-source=("$pkgname::git://github.com/alecthomas/ondir.git")
+makedepends=('git')
+source=("git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$pkgname"
+ cd "$_pkgname"
sed -i '/USE_ONENTERLEAVE/c#define USE_ONENTERLEAVE' conf.h
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
make CFLAGS="$CFLAGS "'-DVERSION=\"$(VERSION)\" -DGLOBAL_CONF=\"$(CONF)\"' LDFLAGS="$LDFLAGS"
}
package() {
- cd "$pkgname"
+ cd "$_pkgname"
make DESTDIR="$pkgdir" install
}