summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
-rw-r--r--onioncat.install9
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd61103fec7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = onioncat-svn
+ pkgdesc = An IP-Transparent Tor Hidden Service Connector
+ pkgver = 561
+ pkgrel = 3
+ url = http://www.cypherpunk.at/onioncat/
+ install = onioncat.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = subversion
+ depends = tor
+ provides = onioncat
+ conflicts = onioncat
+ source = onioncat.install
+ source = onioncat::svn+https://www.cypherpunk.at/svn/onioncat/trunk
+ md5sums = 7ccaf9425ef6adeb962f27a9fafa6256
+ md5sums = SKIP
+
+pkgname = onioncat-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8674808a08a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=onioncat-svn
+pkgver=561
+pkgrel=3
+pkgdesc="An IP-Transparent Tor Hidden Service Connector"
+arch=('i686' 'x86_64')
+url="http://www.cypherpunk.at/onioncat/"
+license=('GPL3')
+depends=('tor')
+makedepends=("subversion")
+conflicts=('onioncat')
+provides=('onioncat')
+install=onioncat.install
+source=(onioncat.install)
+md5sums=( '7ccaf9425ef6adeb962f27a9fafa6256' )
+
+_svntrunk=https://www.cypherpunk.at/svn/onioncat/trunk
+_svnmod=onioncat
+
+source+=("$_svnmod::svn+$_svntrunk")
+md5sums+=("SKIP")
+
+pkgver() {
+ cd "$srcdir"/$_svnmod
+ svnversion | tr -d [A-z]
+}
+
+build() {
+ cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_svnmod-build"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_svnmod-build"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/onioncat.install b/onioncat.install
new file mode 100644
index 000000000000..9ec8cc00eb20
--- /dev/null
+++ b/onioncat.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "See http://www.abenteuerland.at/onioncat/ for configuration and usage."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: