summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78f3d875fa1b..c1b52236c88f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opam-git
pkgdesc = OCaml package manager
- pkgver = 2.1.0.beta2.r165.g1138d481
- pkgrel = 3
+ pkgver = 2.1.0.beta4.r13.g6929b39c
+ pkgrel = 1
url = https://opam.ocaml.org/
arch = i686
arch = x86_64
@@ -17,9 +17,9 @@ pkgbase = opam-git
optdepends = git: For downloading packages with git
optdepends = mercurial: For downloading packages with mercurial
optdepends = rsync: For downloading packages with rsync
- provides = opam
+ provides = _opam-git
conflicts = opam
- source = opam::git+git://github.com/ocaml/opam.git
+ source = git://github.com/ocaml/opam.git
sha256sums = SKIP
pkgname = opam-git
diff --git a/PKGBUILD b/PKGBUILD
index 9311e26dcb67..69b133d00b15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
# Contributor: Raphaƫl Proust <raphlalou@gmail.com>
-pkgname=opam-git
-pkgver=2.1.0.beta2.r165.g1138d481
-pkgrel=3
+_pkgname=opam
+pkgname=$_pkgname-git
+pkgver=2.1.0.beta4.r13.g6929b39c
+pkgrel=1
pkgdesc='OCaml package manager'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url='https://opam.ocaml.org/'
@@ -17,18 +18,18 @@ optdepends=(
'mercurial: For downloading packages with mercurial'
'rsync: For downloading packages with rsync'
)
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}"::'git+git://github.com/ocaml/opam.git')
+provides=(_$pkgname)
+conflicts=($_pkgname)
+source=('git://github.com/ocaml/opam.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/$_pkgname"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/$_pkgname"
# A clean environment seems mandatory to avoid conflicts with
# existing installation of Opam packages. This may cause surprises
# if you have a peculiar customization of your OCaml/Opam setup.
@@ -37,6 +38,6 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir" install
}