summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--duelyst.desktop10
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6dc749655e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = open-duelyst-bin
+ pkgdesc = Duelyst is a digital collectible card game and turn-based strategy hybrid, developed by Counterplay Games
+ pkgver = 1.97.13
+ pkgrel = 1
+ url = https://github.com/open-duelyst/duelyst
+ arch = x86_64
+ license = CC01.0
+ depends = gconf
+ noextract = duelyst-desktop-v1.97.13-linux-x64.zip
+ source = https://github.com/open-duelyst/duelyst/releases/download/1.97.13/duelyst-desktop-v1.97.13-linux-x64.zip
+ source = duelyst.desktop
+ sha256sums = a0f44d8f92354de449e60759592c6495daf1e64b198b1f88b1fbf316c356de48
+ sha256sums = 09f05f3a7f8fba4e7e5f7a070fba1f9005b25661bef86de891cbecd94ab2dde4
+
+pkgname = open-duelyst-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..068bf3b1fdb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+_pkgname="duelyst"
+pkgname="open-duelyst-bin"
+pkgver=1.97.13
+pkgrel=1
+pkgdesc="Duelyst is a digital collectible card game and turn-based strategy hybrid, developed by Counterplay Games"
+arch=("x86_64")
+url='https://github.com/open-duelyst/duelyst'
+license=('CC01.0')
+makedepends=()
+depends=('gconf')
+noextract=("duelyst-desktop-v${pkgver}-linux-x64.zip")
+source=("https://github.com/open-duelyst/duelyst/releases/download/${pkgver}/duelyst-desktop-v${pkgver}-linux-x64.zip"
+ "duelyst.desktop")
+sha256sums=('a0f44d8f92354de449e60759592c6495daf1e64b198b1f88b1fbf316c356de48'
+ '09f05f3a7f8fba4e7e5f7a070fba1f9005b25661bef86de891cbecd94ab2dde4')
+
+
+package() {
+ install -dm755 "${pkgdir}/opt/${_pkname}"
+ install -dm755 "${pkgdir}/usr/local/bin"
+ install -dm755 "${pkgdir}/usr/share/applications"
+
+ unzip duelyst-desktop-v${pkgver}-linux-x64.zip -d "${pkgdir}/opt/${_pkgname}"
+
+ ln -s /opt/${pkgdir}/Duelyst "${pkgdir}/usr/local/bin/${_pkgname}"
+
+ # install desktop entry
+ install -D -m644 ${_pkgname}.desktop $pkgdir/usr/share/applications/${_pkgname}.desktop
+}
diff --git a/duelyst.desktop b/duelyst.desktop
new file mode 100644
index 000000000000..f8facf4039f7
--- /dev/null
+++ b/duelyst.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=duelyst
+Comment=duelyst
+Exec=duelyst
+Icon=duelyst
+Terminal=false
+StartupNotify=false
+Categories=Games;