summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c70e2f61a98f..805c4f4e73b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = opendict
pkgdesc = Multiplatform computer dictionary software
pkgver = 0.6.8
- pkgrel = 2
+ pkgrel = 3
url = http://opendict.sourceforge.net/
arch = any
license = GPL
- depends = python2-wxpython3
+ depends = python-wxpython
depends = xdg-utils
depends = desktop-file-utils
depends = gtk-update-icon-cache
source = opendict-0.6.8.tar.gz::https://github.com/nerijus/opendict/archive/0.6.8.tar.gz
+ source = opendict-python3.diff::https://github.com/nerijus/opendict/commit/49021ad558733189d33789200748f0007fc67b9f.diff
+ source = opendict-python3-2.diff::https://github.com/nerijus/opendict/commit/27b7f8e752f31b16ef4cbd11110bdf14bfae470e.diff
md5sums = 0802d2b1b05ac477339084f3cdda6b3f
+ md5sums = 06b2b3bac041bdf4cb56e4a84f632500
+ md5sums = b6d2371ef426ce68359011aed67967ec
pkgname = opendict
-
diff --git a/PKGBUILD b/PKGBUILD
index fef70874f091..ea27c8ca8487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,26 @@
pkgname=opendict
pkgver=0.6.8
-pkgrel=2
+pkgrel=3
pkgdesc="Multiplatform computer dictionary software"
arch=('any')
url="http://opendict.sourceforge.net/"
license=('GPL')
-depends=('python2-wxpython3' 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/nerijus/${pkgname}/archive/${pkgver}.tar.gz)
-md5sums=('0802d2b1b05ac477339084f3cdda6b3f')
+depends=('python-wxpython' 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/nerijus/${pkgname}/archive/${pkgver}.tar.gz
+ ${pkgname}-python3.diff::https://github.com/nerijus/opendict/commit/49021ad558733189d33789200748f0007fc67b9f.diff
+ ${pkgname}-python3-2.diff::https://github.com/nerijus/opendict/commit/27b7f8e752f31b16ef4cbd11110bdf14bfae470e.diff)
+md5sums=('0802d2b1b05ac477339084f3cdda6b3f'
+ '06b2b3bac041bdf4cb56e4a84f632500'
+ 'b6d2371ef426ce68359011aed67967ec')
prepare() {
cd $pkgname-$pkgver
- # python2 fix
- sed -i 's_/usr/share/doc/packages/python_/usr/lib/python2.7_g' po/Makefile
- sed -i 's_python _python2 _' po/Makefile
- sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' opendict.py
+ # python3 support
+ patch -Np1 -i ${srcdir}/${pkgname}-python3.diff
+ patch -Np1 -i ${srcdir}/${pkgname}-python3-2.diff
}
package() {