summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
-rw-r--r--opendune.install5
-rw-r--r--opendune.pngbin1841 -> 0 bytes
-rw-r--r--opendune.sh25
5 files changed, 18 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6c6c15c20fe..6957ce229395 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opendune-git
pkgdesc = Open source re-creation of the popular game Dune II
- pkgver = 0.7.88d5666
+ pkgver = 0.9.r33.g4ee71cf7
pkgrel = 1
url = http://opendune.org
install = opendune.install
@@ -8,19 +8,17 @@ pkgbase = opendune-git
arch = x86_64
license = GPL2
makedepends = git
- depends = sdl
+ depends = sdl2_image
depends = alsa-lib
+ depends = libpulse
+ depends = hicolor-icon-theme
optdepends = timidity++: midi music support
provides = opendune
conflicts = opendune
source = opendune::git+https://github.com/OpenDUNE/OpenDUNE.git
- source = opendune.sh
source = opendune.desktop
- source = opendune.png
sha256sums = SKIP
- sha256sums = 56a2802f74b2bce644a34a7c2519307ec5925dbc111a1f132f6a19ef4b5e00f0
sha256sums = b80429ce421d6f781b1ef0c7c50293cf5970225e8de0fd6e379290d1fd91d4d7
- sha256sums = 89c9cbf76b3f7ac62bf39235a64b191ee4b3bd437f88161b6757b6ec44e8888b
pkgname = opendune-git
diff --git a/PKGBUILD b/PKGBUILD
index 88424925543e..961e5d6b4b87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,43 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
_pkgbase=opendune
pkgname=$_pkgbase-git
-pkgver=0.7.88d5666
+pkgver=0.9.r33.g4ee71cf7
pkgrel=1
pkgdesc="Open source re-creation of the popular game Dune II"
arch=('i686' 'x86_64')
url="http://opendune.org"
license=('GPL2')
-depends=('sdl' 'alsa-lib')
+depends=('sdl2_image' 'alsa-lib' 'libpulse' 'hicolor-icon-theme')
makedepends=('git')
optdepends=('timidity++: midi music support')
conflicts=('opendune')
provides=('opendune')
install=$_pkgbase.install
source=($_pkgbase::"git+https://github.com/OpenDUNE/OpenDUNE.git"
- "$_pkgbase.sh"
- "$_pkgbase.desktop"
- "$_pkgbase.png")
+ "$_pkgbase.desktop")
sha256sums=('SKIP'
- '56a2802f74b2bce644a34a7c2519307ec5925dbc111a1f132f6a19ef4b5e00f0'
- 'b80429ce421d6f781b1ef0c7c50293cf5970225e8de0fd6e379290d1fd91d4d7'
- '89c9cbf76b3f7ac62bf39235a64b191ee4b3bd437f88161b6757b6ec44e8888b')
+ 'b80429ce421d6f781b1ef0c7c50293cf5970225e8de0fd6e379290d1fd91d4d7')
pkgver() {
cd $_pkgbase
- # get last annotated tag from packed refs
- echo $(tail -n 2 .git/packed-refs | head -n 1 | cut -d "/" -f 3).$(git rev-parse --short master)
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
}
build() {
cd $_pkgbase
- ./configure --prefix-dir=/opt/opendune
+ ./configure --prefix-dir=/usr --binary-dir=bin
make
}
package() {
cd $_pkgbase
- make INSTALL_ICON_DIR="$pkgdir"/opt/$_pkgbase \
- INSTALL_BINARY_DIR="$pkgdir"/opt/$_pkgbase \
- INSTALL_DOC_DIR="$pkgdir"/opt/$_pkgbase/doc install
+ make INSTALL_DIR="$pkgdir" install
- # install binary, icon and desktop files
- install -Dm755 ../$_pkgbase.sh "$pkgdir"/usr/bin/$_pkgbase
- install -Dm644 bin/data/put_dune2_here.txt "$pkgdir"/opt/$_pkgbase/data/put_dune2_here.txt
- install -Dm644 ../$_pkgbase.png "$pkgdir"/usr/share/pixmaps/$_pkgbase.png
+ # install sample config and desktop file
+ install -m644 bin/opendune.ini.sample "$pkgdir"/usr/share/doc/opendune
install -Dm644 ../$_pkgbase.desktop "$pkgdir"/usr/share/applications/$_pkgbase.desktop
}
diff --git a/opendune.install b/opendune.install
index 947e89baf6d2..2b027776ee84 100644
--- a/opendune.install
+++ b/opendune.install
@@ -1,6 +1,9 @@
post_install() {
- echo "Remember you need to be in the audio group and start timidity, eg 'timidity -iA' for music support."
+ echo "Copy the sample configuration file, if needed and change path to data files:"
+ echo "install -D /usr/share/doc/opendune/opendune.ini.sample ~/.config/opendune/opendune.ini"
+
+ echo "Remember you need to start timidity, eg 'timidity -iA' for music support."
}
post_upgrade() {
diff --git a/opendune.png b/opendune.png
deleted file mode 100644
index ce2adb7174af..000000000000
--- a/opendune.png
+++ /dev/null
Binary files differ
diff --git a/opendune.sh b/opendune.sh
deleted file mode 100644
index 00b9f9ecb76e..000000000000
--- a/opendune.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-#
-# OpenDUNE launcher // carstene1ns 2013
-#
-# Does some juggling with the data files and path
-
-[ ! -d $HOME/.opendune/data ] && mkdir -p $HOME/.opendune/data
-
-if [ ! -f $HOME/.opendune/data/put_dune2_here.cfg ]; then
-
- cp /opt/opendune/data/put_dune2_here.txt $HOME/.opendune/data/
-
-fi
-
-if [ -f $HOME/.opendune/data/dune.pak ]; then
-
- cd $HOME/.opendune
- /opt/opendune/opendune "$@"
- cd - &>/dev/null
-
-else
-
- echo "Please place Dune II data files in \"~/.opendune/data\"."
-
-fi