summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD36
-rw-r--r--user-env.patch19
4 files changed, 33 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d355b077804e..e62e6eacfdb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = openfortigui
+pkgbase = openfortigui-git
pkgdesc = OpenFortiGUI is an open-source VPN-Client to connect to Fortigate VPN-Hardware. It is based on openfortivpn and adds an easy to use and nice GUI on top of it, written in Qt5.
- pkgver = 0.9.6
+ pkgver = 0.9.8.1.r0.g31eff99
pkgrel = 1
url = https://github.com/theinvisible/openfortigui.git
arch = i686
@@ -13,9 +13,9 @@ pkgbase = openfortigui
depends = openssl
depends = ppp
depends = sudo
- source = git+https://github.com/theinvisible/openfortigui.git#tag=v0.9.6
- source = user-env.patch
- md5sums = SKIP
- md5sums = 7f1e96dea4ce324b59b8190640f22c43
+ provides = openfortigui
+ conflicts = openfortigui
+ source = git+https://github.com/theinvisible/openfortigui.git
+ b2sums = SKIP
-pkgname = openfortigui
+pkgname = openfortigui-git
diff --git a/.gitignore b/.gitignore
index fa6c81f6b714..1d65adf6de3a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
-openfortigui/
-src/
-pkg/
-openfortigui-*.tar.xz \ No newline at end of file
+*
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 5faf16fbb41d..4cc7da8f5167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,9 @@
-# Maintainer: Charles Delfly <charles@delfly.fr>
-pkgname=openfortigui
-pkgver=0.9.6
+# Maintainer: Josef Vybíhal <josef.vybihal@gmail.com>
+# Contributor: Charles Delfly <charles@delfly.fr>
+
+pkgname=openfortigui-git
+_pkgname="${pkgname%-git}"
+pkgver=0.9.8.1.r0.g31eff99
pkgrel=1
pkgdesc="OpenFortiGUI is an open-source VPN-Client to connect to Fortigate VPN-Hardware. It is based on openfortivpn and adds an easy to use and nice GUI on top of it, written in Qt5."
arch=('i686' 'x86_64')
@@ -9,40 +12,47 @@ license=('GPL3')
groups=()
depends=('qt5-base' 'qtkeychain' 'qt5-translations' 'openssl' 'ppp' 'sudo')
makedepends=('git')
-provides=()
-conflicts=()
+provides=(openfortigui)
+conflicts=(openfortigui)
replaces=()
options=()
install=
-source=("git+https://github.com/theinvisible/$pkgname.git#tag=v$pkgver" "user-env.patch")
+source=("git+https://github.com/theinvisible/$_pkgname.git")
noextract=()
-md5sums=('SKIP' '7f1e96dea4ce324b59b8190640f22c43')
+b2sums=('SKIP')
+#options=(debug !strip)
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${_pkgname}"
cd openfortigui
git submodule init
git submodule update
cd ..
- patch -p1 < ../user-env.patch
+ #patch -p1 < ../user-env.patch
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${_pkgname}"
+ #qmake openfortigui-project.pro -spec linux-g++ CONFIG+=debug CONFIG+=qml_debug
qmake
make
}
check() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${_pkgname}"
make -k check
}
package() {
- cd "$srcdir/$pkgname/openfortigui"
+ cd "$srcdir/${_pkgname}/${_pkgname}"
mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/pixmaps $pkgdir/usr/share/applications $pkgdir/etc/sudoers.d $pkgdir/etc/openfortigui/vpnprofiles
install -m 755 openfortigui $pkgdir/usr/bin/
- chmod 640 $pkgdir/etc/sudoers.d
+ #chmod 640 $pkgdir/etc/sudoers.d
install -m 440 sudo/openfortigui $pkgdir/etc/sudoers.d
install -m 644 app-entry/openfortigui.png $pkgdir/usr/share/pixmaps/
install -m 644 app-entry/openfortigui.desktop $pkgdir/usr/share/applications/
diff --git a/user-env.patch b/user-env.patch
deleted file mode 100644
index 090801ceb077..000000000000
--- a/user-env.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/openfortigui/app-entry/openfortigui.desktop b/openfortigui/app-entry/openfortigui.desktop
-index 41b98d4..16a07a8 100644
---- a/openfortigui/app-entry/openfortigui.desktop
-+++ b/openfortigui/app-entry/openfortigui.desktop
-@@ -3,6 +3,6 @@ Type=Application
- Name=openFortiGUI
- Comment=GUI for openfortivpn
- Icon=/usr/share/pixmaps/openfortigui.png
--Exec=/usr/bin/openfortigui
-+Exec=openfortigui
- Terminal=false
- Categories=Network;Application;
-diff --git a/openfortigui/sudo/openfortigui b/openfortigui/sudo/openfortigui
-index dd594aa..714360b 100644
---- a/openfortigui/sudo/openfortigui
-+++ b/openfortigui/sudo/openfortigui
-@@ -1 +1 @@
--%sudo ALL=NOPASSWD:SETENV: /usr/bin/openfortigui --start-vpn *
-+%wheel ALL=NOPASSWD:SETENV: /usr/bin/openfortigui --start-vpn *