summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--allow-no-unused-functions.patch8
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c74583abb22..7577dcb647bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openfortivpn
pkgdesc = An open implementation of Fortinet's proprietary PPP+SSL VPN solution
- pkgver = 1.3.1
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/adrienverge/openfortivpn
arch = i686
@@ -10,10 +10,10 @@ pkgbase = openfortivpn
depends = openssl
depends = ppp
backup = etc/openfortivpn/config
- source = git+https://github.com/adrienverge/openfortivpn.git#tag=v1.3.1
+ source = git+https://github.com/adrienverge/openfortivpn.git#tag=v1.5.0
source = allow-no-unused-functions.patch
md5sums = SKIP
- md5sums = a4a91e1da771c2a5fdd00153f4695352
+ md5sums = cb2d5a8b3f799ec3d0267722f0a0206b
pkgname = openfortivpn
diff --git a/PKGBUILD b/PKGBUILD
index d45fe99928d1..7af34809944e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Patrick Hanft <mail@patrick-hanft.de>
pkgname=openfortivpn
-pkgver=1.3.1
+pkgver=1.5.0
pkgrel=1
pkgdesc="An open implementation of Fortinet's proprietary PPP+SSL VPN solution"
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ install=
source=("git+https://github.com/adrienverge/$pkgname.git#tag=v$pkgver" "allow-no-unused-functions.patch")
noextract=()
md5sums=('SKIP'
- 'a4a91e1da771c2a5fdd00153f4695352')
+ 'cb2d5a8b3f799ec3d0267722f0a0206b')
prepare() {
cd "$srcdir/$pkgname"
diff --git a/allow-no-unused-functions.patch b/allow-no-unused-functions.patch
index 3e6a43107128..9b59d41f553f 100644
--- a/allow-no-unused-functions.patch
+++ b/allow-no-unused-functions.patch
@@ -1,5 +1,5 @@
---- Makefile.am 2017-08-29 21:03:14.128011847 +0200
-+++ Makefile.am.new 2017-08-29 21:06:54.734339955 +0200
+--- Makefile.am 2017-08-29 21:16:38.310124393 +0200
++++ Makefile.am.new 2017-08-29 21:17:49.376684858 +0200
@@ -9 +9 @@ openfortivpn_SOURCES = src/config.c src/
--openfortivpn_CFLAGS = -Wall -Werror --pedantic -std=gnu99
-+openfortivpn_CFLAGS = -Wall -Werror --pedantic -std=gnu99 -Wno-unused-function
+-openfortivpn_CFLAGS = -Wall --pedantic -std=gnu99
++openfortivpn_CFLAGS = -Wall --pedantic -std=gnu99 -Wno-unused-function