summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74f6a78e454b..c1637c1bc37c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = openfx-io-git
pkgdesc = A set of Readers/Writers plugins written using the OpenFX standard
- pkgver = Natron.2.4.3.r6.g9fb5ee9
+ pkgver = Natron.2.5.0.r2.gf63c273
pkgrel = 1
url = https://github.com/NatronGitHub/openfx-io
arch = x86_64
license = GPL
- makedepends = opencolorio1
+ makedepends = opencolorio
makedepends = git
depends = ffmpeg
depends = openimageio
diff --git a/PKGBUILD b/PKGBUILD
index 4ce717ace583..927d8ce91bea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-io-git
-pkgver=Natron.2.4.3.r6.g9fb5ee9
+pkgver=Natron.2.5.0.r2.gf63c273
pkgrel=1
arch=('x86_64')
pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
url="https://github.com/NatronGitHub/openfx-io"
license=('GPL')
depends=('ffmpeg' 'openimageio' 'libseexpr2')
-makedepends=('opencolorio1' 'git')
+makedepends=('opencolorio' 'git')
_pkgname=${pkgname%-git}
_url=${url%/${_pkgname}}
@@ -39,17 +39,12 @@ prepare() {
git config submodule.openfx.url ${srcdir}/openfx
git config submodule.SupportExt.url ${srcdir}/openfx-supportext
git config submodule.IOSupport/SequenceParsing.url ${srcdir}/SequenceParsing
- git submodule update
+ git -c protocol.file.allow=always submodule update
cd IOSupport/SequenceParsing
git submodule init
git config submodule.tinydir.url ${srcdir}/tinydir
- git submodule update
- cd ../..
-
- # Change OpenColorIO library references to the version of "opencolorio1" package
- find IOSupport/ -name GenericOCIO.* \
- -exec sed -i 's/include <OpenColorIO/include <OpenColorIO1/' {} \;
+ git -c protocol.file.allow=always submodule update
}
build() {