summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b0543ceffe8..95b3ccf232ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Eldeberen <eldeberen.aur@middleearth.fr>
pkgname=openlibm-casio
pkgver=0.7.5
-pkgrel=1
+pkgrel=2
pkgdesc='Fork of the OpenLibm math library with support for fx-9860G and fx-CG 50'
arch=('i686' 'x86_64')
url="https://gitea.planet-casio.com/Lephenixnoir/OpenLibm"
licence=('custom')
makedepends=('sh-elf-gcc-casio')
options=('!buildflags' '!strip')
-source=("$pkgname-$pkgver.tar.gz::https://gitea.planet-casio.com/Lephenixnoir/OpenLibm/archive/v${pkgver}.tar.gz")
-sha256sums=('445e945750f8940f6c8ebd692f64f39f176353fea3671e6d39585f1f873a10a2')
+source=("$pkgname-$pkgver.tar.gz::https://gitea.planet-casio.com/Lephenixnoir/OpenLibm/archive/${pkgver}-sh3eb.tar.gz")
+sha256sums=('2176ed381d11e6bbdad8052781349b04999947805536fd1d40b150551fb634a3')
prepare() {
cd "${srcdir}/openlibm"
@@ -19,13 +19,13 @@ prepare() {
build() {
cd "$srcdir/openlibm"
_prefix=$(sh-elf-gcc --print-search-dirs | grep install | sed 's/install: //')
- make USEGCC=1 TOOLPREFIX=sh-elf- ARCH=sh3eb libdir="${_prefix}" includedir="${_prefix}/include" libopenlibm.a
+ make USEGCC=1 TOOLPREFIX=sh-elf- CC=sh-elf-gcc AR=sh-elf-ar ARCH=sh3eb libdir="${_prefix}" includedir="${_prefix}/include" libopenlibm.a
}
package() {
cd "$srcdir/openlibm"
_prefix=$(sh-elf-gcc --print-search-dirs | grep install | sed 's/install: //')
- make USEGCC=1 TOOLPREFIX=sh-elf- ARCH=sh3eb libdir="${_prefix}" includedir="${_prefix}/include" DESTDIR="$pkgdir" install-static install-headers
+ make USEGCC=1 TOOLPREFIX=sh-elf- CC=sh-elf-gcc AR=sh-elf-ar ARCH=sh3eb libdir="${_prefix}" includedir="${_prefix}/include" DESTDIR="$pkgdir" install-static install-headers
# Install licence
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"