summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 279356d1b77e..71f571c178ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openlp
pkgdesc = Church presentation software.
- pkgver = 3.1.0
- pkgrel = 1
+ pkgver = 3.1.1
+ pkgrel = 3
url = http://openlp.org/
install = openlp.install
arch = any
@@ -10,7 +10,7 @@ pkgbase = openlp
makedepends = python-pip
makedepends = python-setuptools
depends = python>=3.10
- depends = python<3.12
+ depends = python<3.13
depends = python-pyqt5
depends = phonon-qt5
depends = python-chardet
@@ -19,7 +19,6 @@ pkgbase = openlp
depends = python-pyenchant
depends = python-mako
depends = python-appdirs
- depends = python-sqlalchemy
depends = python-pyodbc
depends = python-pyqt5-webengine
depends = qt5-multimedia
@@ -37,9 +36,9 @@ pkgbase = openlp
optdepends = python-vlc: Multimedia playback
optdepends = python-mysql-connector: Use a mysql/mariadb database
optdepends = python-psycopg2: Use a postgresql database
- source = https://gitlab.com/openlp/openlp/-/archive/3.1.0/openlp-3.1.0.tar.gz
+ source = https://gitlab.com/openlp/openlp/-/archive/3.1.1/openlp-3.1.1.tar.gz
source = openlp.sh
- sha256sums = d40baf9698d84fbcaf1cc3624aca3c157de6e25dbf8b09f54037cd98632ec939
+ sha256sums = c464669a3661b3b23e917cb1508c1bfc8e8c8308ee24c86e7dde94789ea1797c
sha256sums = 19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf
pkgname = openlp
diff --git a/PKGBUILD b/PKGBUILD
index 1d4f7aa5a642..5a381b63f6e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
# Contributor: Macxcool <macx coool at coolnet dot xyz>
pkgname=openlp
-pkgver=3.1.0
-pkgrel=1
+pkgver=3.1.1
+pkgrel=3
pkgdesc="Church presentation software."
arch=('any')
url='http://openlp.org/'
license=('GPLv2')
makedepends=('qt5-tools' 'python-pip' 'python-setuptools')
-depends=('python>=3.10' 'python<3.12' 'python-pyqt5' 'phonon-qt5'
+depends=('python>=3.10' 'python<3.13' 'python-pyqt5' 'phonon-qt5'
'python-chardet' 'python-lxml' 'python-beautifulsoup4' 'python-pyenchant'
- 'python-mako' 'python-appdirs' 'python-sqlalchemy' 'python-pyodbc'
+ 'python-mako' 'python-appdirs' 'python-pyodbc'
'python-pyqt5-webengine' 'qt5-multimedia' 'python-pyqt5-webengine' 'python-alembic'
'python-qtawesome' 'python-websockets' 'python-flask' 'python-flask-cors'
'python-webob' 'python-waitress' 'python-qrcode' 'python-pymediainfo')
@@ -24,7 +24,7 @@ optdepends=('libreoffice-fresh: Display impress presentations'
install=openlp.install
source=("https://gitlab.com/openlp/openlp/-/archive/${pkgver}/openlp-${pkgver}.tar.gz" "openlp.sh")
-sha256sums=('d40baf9698d84fbcaf1cc3624aca3c157de6e25dbf8b09f54037cd98632ec939'
+sha256sums=('c464669a3661b3b23e917cb1508c1bfc8e8c8308ee24c86e7dde94789ea1797c'
'19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf')
package() {