summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD22
-rw-r--r--cstddef.patch11
3 files changed, 32 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf4696f0103e..f55f6bfa574c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openms
pkgdesc = C++ library and tools for LC/MS data management and analyses
- pkgver = 2.6.0
+ pkgver = 2.7.0
pkgrel = 1
url = http://www.openms.de
arch = i686
@@ -14,6 +14,7 @@ pkgbase = openms
makedepends = make
makedepends = patch
depends = boost
+ depends = coin-or-mp
depends = eigen
depends = glpk
depends = hdf5
@@ -21,14 +22,15 @@ pkgbase = openms
depends = qt5-svg
depends = sqlite
depends = xerces-c
- source = https://abibuilder.informatik.uni-tuebingen.de/archive/openms/OpenMSInstaller/release/2.6.0/OpenMS-2.6.0-src.tar.gz
+ source = https://abibuilder.informatik.uni-tuebingen.de/archive/openms/OpenMSInstaller/release/2.7.0/OpenMS-2.7.0-src.tar.gz
source = OpenMS-TOPPView.desktop
source = OpenMS-TOPPAS.desktop
source = OpenMS.sh
- sha256sums = 55f30d09cba420009587e50d70812a4775d012151df8c600c7c39e59079bc10b
+ source = cstddef.patch
+ sha256sums = 62bce6215bc88ca7d1f1b7abf15cea4061bdcfa10dbb1e652b1d8c2ff9b3f081
sha256sums = 4f93d5c22a8267e4fbde6883ecc34a00abfc2ee5eafb46f6d81256ad8a33cdac
sha256sums = 9b33c6c91d931802e88af89ade4beb6c8d05484d57d1ad804888511b7a8b00a0
sha256sums = 2cf69cb56959f101614129d2a87dc078daca904e1701ed674d399afed1ff306d
+ sha256sums = 75c05e06381237fe451abdd8802604d9d67c5dd00fb6f5a744afe4b84dfd0e41
pkgname = openms
-
diff --git a/PKGBUILD b/PKGBUILD
index 754a618f1c80..62038160cdc2 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
# Contributor: saxonbeta <saxonbeta at gmail dot com>
pkgname=openms
_pkgname=OpenMS
-pkgver=2.6.0
-_pkgver=2.6
+pkgver=2.7.0
+_pkgver=2.7
pkgrel=1
pkgdesc="C++ library and tools for LC/MS data management and analyses"
arch=('i686' 'x86_64')
url="http://www.openms.de"
license=('BSD')
-depends=('boost' 'eigen' 'glpk' 'hdf5' 'qt5-base' 'qt5-svg' 'sqlite' 'xerces-c')
+depends=('boost' 'coin-or-mp' 'eigen' 'glpk' 'hdf5' 'qt5-base' 'qt5-svg' 'sqlite' 'xerces-c')
makedepends=('autoconf' 'automake' 'cmake' 'fakeroot' 'gcc' 'make' 'patch')
source=("https://abibuilder.informatik.uni-tuebingen.de/archive/openms/OpenMSInstaller/release/${pkgver}/${_pkgname}-${pkgver}-src.tar.gz"
"OpenMS-TOPPView.desktop"
"OpenMS-TOPPAS.desktop"
- "OpenMS.sh")
-sha256sums=('55f30d09cba420009587e50d70812a4775d012151df8c600c7c39e59079bc10b'
+ "OpenMS.sh"
+ "cstddef.patch")
+sha256sums=('62bce6215bc88ca7d1f1b7abf15cea4061bdcfa10dbb1e652b1d8c2ff9b3f081'
'4f93d5c22a8267e4fbde6883ecc34a00abfc2ee5eafb46f6d81256ad8a33cdac'
'9b33c6c91d931802e88af89ade4beb6c8d05484d57d1ad804888511b7a8b00a0'
- '2cf69cb56959f101614129d2a87dc078daca904e1701ed674d399afed1ff306d')
+ '2cf69cb56959f101614129d2a87dc078daca904e1701ed674d399afed1ff306d'
+ '75c05e06381237fe451abdd8802604d9d67c5dd00fb6f5a744afe4b84dfd0e41')
# Variables
_prefix="${_pkgname}-${pkgver}"
@@ -56,6 +58,11 @@ _build_openms() {
make $@
}
+prepare() {
+ cd "${srcdir}"
+ patch --strip=1 < cstddef.patch
+}
+
build() {
# Variables
@@ -65,7 +72,7 @@ build() {
# Note: We also build SQLITE, since AUR offers sqlite2. If this is installed,
# the build process might erroneously link against sqlite2, which will then
# break the build
- _build_contrib SQLITE SEQAN LIBSVM COINOR KISSFFT WILDMAGIC
+ _build_contrib SQLITE LIBSVM KISSFFT WILDMAGIC
# Build OpenMS
_build_openms OpenMS TOPP UTILS GUI
@@ -80,3 +87,4 @@ package() {
$INSTALL "${srcdir}/OpenMS-TOPPAS.desktop" "${pkgdir}/usr/share/applications/OpenMS-TOPPAS.desktop"
$INSTALL "${srcdir}/OpenMS.sh" "${pkgdir}/etc/profile.d/OpenMS.sh"
}
+
diff --git a/cstddef.patch b/cstddef.patch
new file mode 100644
index 000000000000..815cbfbac8b1
--- /dev/null
+++ b/cstddef.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text package.orig/OpenMS-2.7.0/src/openms/include/OpenMS/DATASTRUCTURES/ParamValue.h package.new/OpenMS-2.7.0/src/openms/include/OpenMS/DATASTRUCTURES/ParamValue.h
+--- package.orig/OpenMS-2.7.0/src/openms/include/OpenMS/DATASTRUCTURES/ParamValue.h 2021-09-13 23:50:44.000000000 +0200
++++ package.new/OpenMS-2.7.0/src/openms/include/OpenMS/DATASTRUCTURES/ParamValue.h 2021-10-03 12:57:22.413618008 +0200
+@@ -37,6 +37,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstddef>
+
+ namespace OpenMS
+ {