summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD75
-rw-r--r--openmw-git.install12
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5985b530171
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = openmw-git
+ pkgdesc = OpenMW is a open-source engine reimplementation for the role-playing game Morrowind.
+ pkgver = 20110922
+ pkgrel = 1
+ url = http://www.openmw.org
+ install = openmw-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = openal
+ depends = ogre
+ depends = bullet
+ depends = ffmpeg
+ depends = mygui
+ depends = mpg123
+ depends = libsndfile
+ depends = qt
+ conflicts = openmw
+
+pkgname = openmw-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fff7509309b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+
+# Maintainer: Pieter van der Kloet <pvdkloet@gmail.com>
+pkgname=openmw-git
+pkgver=20110922
+pkgrel=1
+pkgdesc="OpenMW is a open-source engine reimplementation for the role-playing game Morrowind."
+arch=('i686' 'x86_64')
+url="http://www.openmw.org"
+license=('GPL3')
+
+depends=('openal' 'ogre' 'bullet' 'ffmpeg' 'mygui' 'mpg123' 'libsndfile' 'qt')
+
+makedepends=('git' 'cmake' 'boost')
+install=$pkgname.install
+conflicts=('openmw')
+
+_gitroot="git://github.com/zinnschlag/openmw.git"
+_gitname="openmw"
+
+build() {
+ msg "Connecting to GIT server...."
+
+ if [ -d "$_gitname" ] ; then
+ cd "$_gitname" && git pull origin
+ git submodule update
+ msg "The local files are updated."
+ else
+ cd "$srcdir"
+ git clone "$_gitroot" "$_gitname"
+ cd "$_gitname"
+ git submodule update --init
+ cd "$srcdir"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+
+ # Install
+ # There is currently no make install so we do this manually
+
+ # Binaries
+ install -d -m755 "$pkgdir"/usr/bin
+ install -m755 openmw "$pkgdir"/usr/bin/
+ install -m755 omwlauncher "$pkgdir"/usr/bin/
+ install -m755 esmtool "$pkgdir"/usr/bin/
+
+ # Config files
+ # Replace resources location
+ sed -i 's,resources=resources,resources=/usr/share/openmw/resources,' openmw.cfg.install || exit 1
+
+ install -d -m755 "$pkgdir"/etc/openmw
+ install -m644 openmw.cfg.install "$pkgdir"/etc/openmw/openmw.cfg
+ install -m644 plugins.cfg "$pkgdir"/etc/openmw/
+
+ # Stylesheet
+ install -m644 launcher.qss "$pkgdir"/etc/openmw/
+ ln -s -T /etc/openmw/launcher.qss "$pkgdir"/usr/bin/launcher.qss || exit 1
+
+ # Desktop file and icon
+ install -d -m755 "$pkgdir"/usr/share/applications
+ install -m644 files/openmw.desktop "$pkgdir"/usr/share/applications/
+
+ install -d -m755 "$pkgdir"/usr/share/pixmaps
+ install -m644 apps/launcher/resources/images/openmw.png "$pkgdir"/usr/share/pixmaps/
+
+ # Resources
+ install -d -m755 "$pkgdir"/usr/share/openmw
+ cp -r resources "$pkgdir"/usr/share/openmw/ || exit 1
+
+}
+
+
diff --git a/openmw-git.install b/openmw-git.install
new file mode 100644
index 000000000000..44b7abbf5673
--- /dev/null
+++ b/openmw-git.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ post_install
+}
+
+post_install() {
+ echo -e "\nOpenMW needs the original Morrowind game files to run, and you need to tell OpenMW where they are."
+ echo "You can specify the Data Files location by editing or creating:"
+ echo -e "\n\t/home/<username>/.config/openmw/openmw.cfg\n"
+ echo "Specify the full path to the Data Files directory after data=, no quotes, no escape characters."
+ echo "For example:"
+ echo -e "\n\tdata=/home/<username>/openmw/Data Files\n"
+}