summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--MIT-LICENSE.txt19
-rw-r--r--PKGBUILD34
4 files changed, 26 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07d776d055e7..c5f6e2dae52e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
-# Generated by mksrcinfo v8
-# Sun Apr 17 11:24:48 UTC 2016
pkgbase = opennhrp
pkgdesc = An opensource NHRP implementation
- pkgver = 0.14
+ pkgver = 0.14.1
pkgrel = 1
- url = http://sourceforge.net/projects/opennhrp/
- arch = i686
+ url = https://sourceforge.net/projects/opennhrp
arch = x86_64
- license = custom
+ arch = aarch64
+ license = MIT
depends = linux>=3.7.4-1
depends = bash
depends = c-ares
- source = http://downloads.sourceforge.net/project/opennhrp/opennhrp/opennhrp-0.14.tar.bz2
- source = MIT-LICENSE.txt
- md5sums = 62e8f16dd3bdf0600e43fcb37aa40462
- md5sums = fcde66d6d3a34d2a5c48fcef0b0be04c
+ backup = etc/opennhrp/opennhrp.conf
+ source = https://downloads.sourceforge.net/project/opennhrp/opennhrp/opennhrp-0.14.1.tar.bz2
+ sha256sums = 1517d53d688ffc165a1da20c344d96b4c53e60f34bd73c64e60cb67cfca4e9ab
pkgname = opennhrp
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c6927b4669a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+*.tar.*
diff --git a/MIT-LICENSE.txt b/MIT-LICENSE.txt
deleted file mode 100644
index 27931833e97d..000000000000
--- a/MIT-LICENSE.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-Copyright (c) 2007-2012 Timo Teräs
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index e3e9a5d6440b..6c718e518cf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
-# Maintainer: Shawn Fisher <fishbot@gmail.com>
+# Maintainer: Konstantin Shalygin <k0ste@k0ste.ru>
+# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
-pkgname=opennhrp
-pkgver=0.14
-pkgrel=1
+pkgname='opennhrp'
+pkgver='0.14.1'
+pkgrel='1'
pkgdesc="An opensource NHRP implementation"
-arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/opennhrp/"
-license=('custom')
+arch=('x86_64' 'aarch64')
+url="https://sourceforge.net/projects/${pkgname}"
+license=('MIT')
depends=('linux>=3.7.4-1' 'bash' 'c-ares')
-source=("http://downloads.sourceforge.net/project/opennhrp/opennhrp/$pkgname-$pkgver.tar.bz2"
- 'MIT-LICENSE.txt')
-md5sums=('62e8f16dd3bdf0600e43fcb37aa40462'
- 'fcde66d6d3a34d2a5c48fcef0b0be04c')
+backup=("etc/${pkgname}/${pkgname}.conf")
+source=("https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('1517d53d688ffc165a1da20c344d96b4c53e60f34bd73c64e60cb67cfca4e9ab')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
- make
+ make SBINDIR="/usr/bin"
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
- install -Dm644 "$srcdir/MIT-LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/MIT-LICENSE.txt"
+ make DESTDIR="${pkgdir}" install
+ install -Dm0644 "MIT-LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}
-
-# vim:set ts=2 sw=2 et: