summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--automake17.patch11
-rw-r--r--configure.patch11
4 files changed, 34 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3440f6ab6b0f..d423e1c9a954 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,6 +21,10 @@ pkgbase = opensmtpd-extras
optdepends = mariadb-libs: for table-mysql support
optdepends = hiredis: for table-redis support
source = https://www.opensmtpd.org/archives/opensmtpd-extras-6.7.1.tar.gz
+ source = automake17.patch
+ source = configure.patch
sha512sums = 0969c53a5d13816862f13b3572c0d84d34e2d36d85f83a528d70ee3f4ad5e6b2cdda256529e95a43a177e64368e4e93540d5bb2f81039808d79049234b249d91
+ sha512sums = dec95f5b4d518dff802321fe3d29a05086565b107db62f3c6741c29b0999e9a074bb287a0304c633372b85d46d7675d299caa548e1504d1245efd6e731b175ed
+ sha512sums = 76c24516771a649a44cd3113fc4a884b9c6196582435d10f3f6f2efe0e6c168cfdc222e7bb37bd02e7c879db10b7dfaea174053f4ac863e74ff77920b7938038
pkgname = opensmtpd-extras
diff --git a/PKGBUILD b/PKGBUILD
index fc5fed2eacf6..525ddb8b7b22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,14 +16,20 @@ optdepends=(
'mariadb-libs: for table-mysql support'
'hiredis: for table-redis support'
)
-source=(https://www.opensmtpd.org/archives/$pkgname-$pkgver.tar.gz)
-sha512sums=('0969c53a5d13816862f13b3572c0d84d34e2d36d85f83a528d70ee3f4ad5e6b2cdda256529e95a43a177e64368e4e93540d5bb2f81039808d79049234b249d91')
+source=(https://www.opensmtpd.org/archives/$pkgname-$pkgver.tar.gz automake17.patch configure.patch)
+sha512sums=('0969c53a5d13816862f13b3572c0d84d34e2d36d85f83a528d70ee3f4ad5e6b2cdda256529e95a43a177e64368e4e93540d5bb2f81039808d79049234b249d91' 'dec95f5b4d518dff802321fe3d29a05086565b107db62f3c6741c29b0999e9a074bb287a0304c633372b85d46d7675d299caa548e1504d1245efd6e731b175ed' '76c24516771a649a44cd3113fc4a884b9c6196582435d10f3f6f2efe0e6c168cfdc222e7bb37bd02e7c879db10b7dfaea174053f4ac863e74ff77920b7938038')
prepare() {
cd $pkgname-$pkgver
# Fix config folder location
sed 's#/mail#/smtpd#' -i extras/tables/table-sqlite/sqlite.conf
+
+ # Allow automake 1.17
+ patch -p1 -i "${srcdir}/automake17.patch"
+
+ # Fix this bad compiler check
+ patch -p1 -i "${srcdir}/configure.patch"
}
build() {
diff --git a/automake17.patch b/automake17.patch
new file mode 100644
index 000000000000..e672fe0bb25b
--- /dev/null
+++ b/automake17.patch
@@ -0,0 +1,11 @@
+--- a/bootstrap 2024-09-17 14:52:50.849035871 -0700
++++ b/bootstrap 2024-09-17 14:53:17.125981281 -0700
+@@ -36,7 +36,7 @@
+
+ # Check for automake
+ amvers="no"
+-for v in 16 15 14 13; do
++for v in 17 16 15 14 13; do
+ if automake-1.${v} --version >/dev/null 2>&1; then
+ amvers="-1.${v}"
+ break
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..f259c87bd2a6
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2020-04-06 11:36:29.000000000 -0700
++++ b/configure.ac 2024-09-17 15:23:35.927906026 -0700
+@@ -312,7 +312,7 @@
+ AM_CONDITIONAL([NO_LIBASR], [test x$asr_in_libc = x1])
+
+ AC_MSG_CHECKING([compiler and flags for sanity])
+-AC_RUN_IFELSE([AC_LANG_PROGRAM([[ #include <stdio.h> ]], [[ exit(0); ]])],
++AC_RUN_IFELSE([AC_LANG_PROGRAM([[ #include <stdlib.h> ]], [[ exit(0); ]])],
+ [ AC_MSG_RESULT([yes]) ],
+ [
+ AC_MSG_RESULT([no])