summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
-rw-r--r--openspades.patch35
3 files changed, 62 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a525c3e13893..54a3b55fd093 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 10 22:46:23 UTC 2015
+# Mon Mar 7 00:31:55 UTC 2016
pkgbase = openspades-git
pkgdesc = A clone of Voxlap Ace of Spades 0.75 (git version)
- pkgver = 0.0.12.59.g50abf95
- pkgrel = 1
+ pkgver = 0.0.12.84.g355d1f2
+ pkgrel = 2
url = https://github.com/yvt/openspades
install = openspades.install
arch = i686
@@ -23,8 +23,10 @@ pkgbase = openspades-git
depends = sdl2_image
provides = openspades
conflicts = openspades
- source = openspades-git::git://github.com/yvt/openspades.git
+ source = openspades-git::git+https://github.com/yvt/openspades.git
+ source = openspades.patch
md5sums = SKIP
+ md5sums = f8b429ee14d92598fd684fcf4ce3097e
pkgname = openspades-git
diff --git a/PKGBUILD b/PKGBUILD
index dfe79a51c5d4..d97278d46c89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: kusakata <shohei atmark kusakata period com>
pkgname=openspades-git
-pkgver=0.0.12.59.g50abf95
-pkgrel=1
+pkgver=0.0.12.84.g355d1f2
+pkgrel=2
pkgdesc="A clone of Voxlap Ace of Spades 0.75 (git version)"
arch=('i686' 'x86_64')
url="https://github.com/yvt/openspades"
@@ -14,22 +14,31 @@ makedepends=('cmake' 'git' 'unzip' 'wget')
provides=('openspades')
conflicts=('openspades')
install=openspades.install
-source=("$pkgname"::'git://github.com/yvt/openspades.git')
-md5sums=('SKIP')
+source=("$pkgname"::'git+https://github.com/yvt/openspades.git'
+ 'openspades.patch')
+md5sums=('SKIP'
+ 'f8b429ee14d92598fd684fcf4ce3097e')
+
+prepare() {
+ # Note: this being the git version, possibly soon be fixed/modified upstream and patch becomes obsolete/invalid
+ # if patching or building with this patch fails, please notify the package maintainer
+ cd "${srcdir}/${pkgname}"
+ patch -p1 -i ${srcdir}/openspades.patch
+}
pkgver() {
- cd "$pkgname"
- git describe --tags | sed 's/^v//' | sed 's/-/./g'
+ cd "$pkgname"
+ git describe --tags | sed 's/^v//' | sed 's/-/./g'
}
build() {
- cd "$pkgname"
- cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release -D OPENSPADES_RESDIR=/usr/share/openspades-git/Resources -D OPENSPADES_INSTALL_RESOURCES=share/openspades-git/Resources -D OPENSPADES_INSTALL_BINARY=bin .
- make
+ cd "$pkgname"
+ cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release -D OPENSPADES_RESDIR=/usr/share/openspades-git/Resources -D OPENSPADES_INSTALL_RESOURCES=share/openspades-git/Resources -D OPENSPADES_INSTALL_BINARY=bin .
+ make
}
package() {
- cd "$pkgname"
- make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}/usr/share/menu"
+ cd "$pkgname"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/share/menu"
}
diff --git a/openspades.patch b/openspades.patch
new file mode 100644
index 000000000000..7923b0ac9828
--- /dev/null
+++ b/openspades.patch
@@ -0,0 +1,35 @@
+diff -aur openspades-0.0.12.pristine/Sources/Client/Client_Input.cpp openspades-0.0.12.new/Sources/Client/Client_Input.cpp
+--- openspades-0.0.12.pristine/Sources/Client/Client_Input.cpp 2016-03-07 10:11:47.126752964 +1030
++++ openspades-0.0.12.new/Sources/Client/Client_Input.cpp 2016-03-07 10:13:31.009665382 +1030
+@@ -38,6 +38,7 @@
+
+ #include "NetClient.h"
+
++using namespace std;
+
+ SPADES_SETTING(cg_mouseSensitivity, "1");
+ SPADES_SETTING(cg_zoomedMouseSensScale, "0.6");
+diff -aur openspades-0.0.12.pristine/Sources/Client/Corpse.cpp openspades-0.0.12.new/Sources/Client/Corpse.cpp
+--- openspades-0.0.12.pristine/Sources/Client/Corpse.cpp 2016-03-07 10:11:47.126752964 +1030
++++ openspades-0.0.12.new/Sources/Client/Corpse.cpp 2016-03-07 10:13:31.049663957 +1030
+@@ -27,6 +27,8 @@
+ #include "../Core/Debug.h"
+ #include "../Core/Settings.h"
+
++using namespace std;
++
+ SPADES_SETTING(r_corpseLineCollision, "1");
+
+ namespace spades {
+diff -aur openspades-0.0.12.pristine/Sources/Draw/SWMapRenderer.cpp openspades-0.0.12.new/Sources/Draw/SWMapRenderer.cpp
+--- openspades-0.0.12.pristine/Sources/Draw/SWMapRenderer.cpp 2016-03-07 10:11:47.133419386 +1030
++++ openspades-0.0.12.new/Sources/Draw/SWMapRenderer.cpp 2016-03-07 10:13:31.092995748 +1030
+@@ -31,6 +31,8 @@
+ #include "SWUtils.h"
+ #include <cstdint>
+
++using namespace std;
++
+ SPADES_SETTING(r_swUndersampling, "0");
+
+ namespace spades {