summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0999c24a8a7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Aug 3 13:12:49 UTC 2017
+pkgbase = openspin
+ pkgdesc = Open Source Spin interpreter for the Parallax Propeller
+ pkgver = 1.00.78
+ pkgrel = 1
+ url = https://github.com/parallaxinc/OpenSpin
+ arch = x86_64
+ arch = i686
+ license = unknown
+ provides = openspin
+ conflicts = openspin-git
+ source = https://github.com/parallaxinc/OpenSpin/archive/1.00.78.tar.gz
+ md5sums = 773eac415d3adfdc1b909376ec3ecda3
+
+pkgname = openspin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29025d445d27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Uffe Jakobsen _<_uffe_at_uffe_dot_org_>_
+pkgname=openspin
+_pkgname=OpenSpin
+pkgver=1.00.78
+pkgrel=1
+pkgdesc="Open Source Spin interpreter for the Parallax Propeller"
+arch=('x86_64' 'i686')
+url="https://github.com/parallaxinc/OpenSpin"
+license=('unknown')
+groups=()
+depends=()
+makedepends=()
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+replaces=()
+backup=()
+options=()
+install=
+source=("https://github.com/parallaxinc/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('773eac415d3adfdc1b909376ec3ecda3')
+
+
+build()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make
+}
+
+package()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -Dm 755 build/openspin "${pkgdir}/usr/bin/openspin"
+}
+
+#
+# EOF
+#