summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23b1a362e310
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = openswitcher-git
+ pkgdesc = BlackMagic Atem control software implementation
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://git.sr.ht/~martijnbraam/pyatem
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = python
+ depends = python-pyusb
+ source = git+https://git.sr.ht/~martijnbraam/pyatem
+ md5sums = SKIP
+
+pkgname = openswitcher-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de68a78b660c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nicolas Goy <me@kuon.ch>
+
+pkgname=openswitcher-git
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="BlackMagic Atem control software implementation"
+arch=("any")
+url="https://git.sr.ht/~martijnbraam/pyatem"
+license=('GPL3')
+groups=()
+depends=('python' 'python-pyusb')
+makedepends=('git' 'meson')
+source=("git+https://git.sr.ht/~martijnbraam/pyatem")
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/pyatem
+ python setup.py build
+ meson build --prefix /usr
+ meson compile -C build
+}
+
+package() {
+ cd $srcdir/pyatem
+ python setup.py install --root "$pkgdir"
+ DESTDIR=$pkgdir meson install -C build
+}