summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
-rw-r--r--opentk-compat.pc.in9
-rw-r--r--opentk-winforms.pc.in9
-rw-r--r--opentk.pc.in8
6 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..140064f2d1e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = opentk
+ pkgver = 1.1_4c
+ pkgrel = 1
+ epoch = 2
+ url = http://www.opentk.com
+ arch = any
+ license = MIT
+ makedepends = doxygen
+ makedepends = texlive-core
+ makedepends = ghostscript
+ options = !emptydirs
+ source = https://github.com/opentk/opentk/archive/1.1-4c.tar.gz
+ source = opentk.pc.in
+ source = opentk-winforms.pc.in
+ source = opentk-compat.pc.in
+ sha1sums = 1eae1729720eb06cdd22ad6372346e2aa37b55c1
+ sha1sums = 1af9b1b5edd2b56023bf85c7aa79d6867fa6c94c
+ sha1sums = b30246f657626e2223c252fbf9d176f32e56fb18
+ sha1sums = 933814784c3f73f007ed899abfea16e990c2836b
+
+pkgname = opentk
+ pkgdesc = Open source game development toolkit for .Net/Mono.
+ depends = mono
+ depends = sdl2
+ depends = openal
+
+pkgname = opentk-docs
+ pkgdesc = OpenTK documentation
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a2223f3641d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..938d150cd533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+pkgbase=opentk
+pkgname=(opentk opentk-docs)
+epoch=2
+pkgver=1.1_4c
+pkgrel=1
+arch=(any)
+license=("MIT")
+makedepends=(doxygen texlive-core ghostscript)
+options=(!emptydirs)
+url="http://www.opentk.com"
+source=("https://github.com/opentk/opentk/archive/${pkgver//_/-}.tar.gz"
+"opentk.pc.in"
+"opentk-winforms.pc.in"
+"opentk-compat.pc.in")
+sha1sums=('1eae1729720eb06cdd22ad6372346e2aa37b55c1'
+ '1af9b1b5edd2b56023bf85c7aa79d6867fa6c94c'
+ 'b30246f657626e2223c252fbf9d176f32e56fb18'
+ '933814784c3f73f007ed899abfea16e990c2836b')
+
+prepare() {
+ cd "$srcdir/opentk-${pkgver//_/-}/Source/Examples"
+ sed -i "s,debug.log,/tmp/opentk_debug.log," ExampleBrowser.cs
+ sed -i -e "s,debug.log,/tmp/opentk_debug.log,g" -e "s,trace.log,/tmp/opentk_trace.log,g" Main.cs
+}
+
+build() {
+ cd "$srcdir/opentk-${pkgver//_/-}/Source/Build.UpdateVersion"
+ xbuild Build.UpdateVersion.csproj /p:Configuration=Release
+ cd ../..
+ xbuild OpenTK.sln /p:Configuration=Release
+ cd Documentation
+ doxygen
+}
+
+package_opentk() {
+ pkgdesc="Open source game development toolkit for .Net/Mono."
+ depends=(mono sdl2 openal)
+ cd "$srcdir/opentk-${pkgver//_/-}/Binaries/OpenTK/Release"
+ rm *.xml
+ find . -type f -exec install -Dm644 {} "$pkgdir/usr/lib/opentk/"{} \;
+ find "$pkgdir" -name 'OpenTK*.dll' -exec gacutil -i {} -root "$pkgdir/usr/lib" \;
+ cd ../../../Documentation
+ install -Dm644 "License.txt" "$pkgdir/usr/share/licenses/$pkgname/License.txt"
+ install -Dm644 "$srcdir/opentk.pc.in" "$pkgdir/usr/lib/pkgconfig/opentk.pc"
+ install -m644 "$srcdir/opentk-winforms.pc.in" "$pkgdir/usr/lib/pkgconfig/opentk-winforms.pc"
+ install -m644 "$srcdir/opentk-compat.pc.in" "$pkgdir/usr/lib/pkgconfig/opentk-compat.pc"
+ find "$pkgdir/usr/lib/pkgconfig" -type f -exec sed -i "s|@VERSION@|${pkgver//_/-}|" {} \;;
+}
+
+package_opentk-docs() {
+ pkgdesc="OpenTK documentation"
+ cd "$srcdir/opentk-${pkgver//_/-}/Documentation/Source"
+ find . -type f -exec install -Dm644 {} "$pkgdir/usr/share/doc/opentk/"{} \;
+}
diff --git a/opentk-compat.pc.in b/opentk-compat.pc.in
new file mode 100644
index 000000000000..9d87f8400488
--- /dev/null
+++ b/opentk-compat.pc.in
@@ -0,0 +1,9 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/lib
+
+Name: OpenTK
+Description: Open source game development toolkit for .Net/Mono.
+Version: @VERSION@
+Requires: opentk
+Libs: -r:${libdir}/opentk/OpenTK.Compatibility.dll
diff --git a/opentk-winforms.pc.in b/opentk-winforms.pc.in
new file mode 100644
index 000000000000..398bbb2ca5f2
--- /dev/null
+++ b/opentk-winforms.pc.in
@@ -0,0 +1,9 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/lib
+
+Name: OpenTK.GLControl
+Description: Open source game development toolkit for .Net/Mono.
+Version: @VERSION@
+Requires: opentk
+Libs: -r:${libdir}/opentk/OpenTK.GLControl.dll
diff --git a/opentk.pc.in b/opentk.pc.in
new file mode 100644
index 000000000000..a77ea14224a3
--- /dev/null
+++ b/opentk.pc.in
@@ -0,0 +1,8 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/lib
+
+Name: OpenTK
+Description: Open source game development toolkit for .Net/Mono.
+Version: @VERSION@
+Libs: -r:${libdir}/opentk/OpenTK.dll