summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37fb0e0cf447..2cba9ceacf20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openvr
pkgdesc = API and runtime that allows access to VR hardware
pkgver = 1.14.15
- pkgrel = 1
+ pkgrel = 2
url = https://www.steamvr.com/en/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index e9a05b77bc78..400a6ef2408f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=openvr
pkgver=1.14.15
-pkgrel=1
+pkgrel=2
pkgdesc="API and runtime that allows access to VR hardware"
arch=('x86_64')
url="https://www.steamvr.com/en/"
@@ -31,23 +31,22 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- mkdir -p "_build" && cd "_build"
cmake \
+ -B "_build" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
- "../"
- make
- cd ..
+ ./
+ make -C "_build"
cd "samples"
- mkdir -p "_build" && cd "_build"
cmake \
+ -B "_build" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
- "../"
- make
+ ./
+ make -C "_build"
}
package() {