summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
-rw-r--r--install4
-rw-r--r--oragono.service3
-rw-r--r--path.patch41
5 files changed, 69 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a758d300956f..37ed5fff0380 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = oragono
pkgdesc = A modern IRC server written in Go.
- pkgver = 0.8.0
+ pkgver = 0.8.1
pkgrel = 1
url = https://github.com/oragono/oragono
+ install = install
arch = x86_64
license = MIT
makedepends = go
makedepends = git
- makedepends = zip
- backup = opt/oragono/ircd.yaml
- source = git+https://github.com/oragono/oragono#commit=f051b43f2737f5ec6b0c97e27f5227f525015c41
+ backup = etc/oragono.conf
+ source = git+https://github.com/oragono/oragono#commit=325ed3e112f076aa0d717437a18ef331281db821
source = oragono.service
+ source = path.patch
sha256sums = SKIP
- sha256sums = f3a21d66d86d9e90bb080a10e05aef67c9541a6a3c4c4c2e1c963d374f83cb9e
+ sha256sums = 131097e2803dee6f0b00de41b80fb790a44dd6c90bf1b1004078535150ff64cc
+ sha256sums = 25a1c0f764283059e95088f3b9cb66fe6a0c95df0d9dc8375856f41097c04fb0
pkgname = oragono
diff --git a/PKGBUILD b/PKGBUILD
index 50cc1307ca03..59a7741b690e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,35 @@
# Maintainer: Sean Enck <enckse@gmail.com>
pkgname=oragono
-pkgver=0.8.0
+pkgver=0.8.1
pkgrel=1
pkgdesc="A modern IRC server written in Go."
arch=('x86_64')
url="https://github.com/oragono/oragono"
license=('MIT')
-makedepends=('go' 'git' 'zip')
-source=("git+$url#commit=f051b43f2737f5ec6b0c97e27f5227f525015c41"
- "oragono.service")
+install=install
+makedepends=('go' 'git')
+source=("git+$url#commit=325ed3e112f076aa0d717437a18ef331281db821"
+ "oragono.service"
+ "path.patch")
sha256sums=('SKIP'
- 'f3a21d66d86d9e90bb080a10e05aef67c9541a6a3c4c4c2e1c963d374f83cb9e')
-backup=('opt/oragono/ircd.yaml')
+ '131097e2803dee6f0b00de41b80fb790a44dd6c90bf1b1004078535150ff64cc'
+ '25a1c0f764283059e95088f3b9cb66fe6a0c95df0d9dc8375856f41097c04fb0')
+backup=('etc/oragono.conf')
build() {
cd ${srcdir}/$pkgname
+ patch -p0 < ../../path.patch
export GOPATH=$(pwd)
go get -v -d
- sed -i "s/DanielOaks/oragono/g" oragono.go
- ./build.sh
+ make linux
+ echo "Arch Linux AUR: $pkgver-$pkgrel" >> build/linux/oragono.motd
}
package() {
- local _opt=/opt/oragono/
+ local _conf=/var/lib/oragono/
install -Dm 644 oragono.service $pkgdir/usr/lib/systemd/system/oragono.service
cd ${srcdir}/$pkgname/build/linux
- install -Dm 755 oragono $pkgdir/$_opt/oragono
- install -Dm 644 oragono.motd $pkgdir/$_opt/oragono.motd
- install -Dm 644 oragono.yaml $pkgdir/$_opt/ircd.yaml
+ install -Dm 755 oragono $pkgdir/usr/bin/oragono
+ install -Dm 644 oragono.motd $pkgdir/$_conf/ircd.motd
+ install -Dm 644 oragono.yaml $pkgdir/etc/oragono.conf
}
diff --git a/install b/install
new file mode 100644
index 000000000000..dc4f4622a2c8
--- /dev/null
+++ b/install
@@ -0,0 +1,4 @@
+post_install() {
+ /usr/bin/oragono initdb --conf /etc/oragono.conf
+ cd /var/lib/oragono/ && /usr/bin/oragono mkcerts --conf /etc/oragono.conf
+}
diff --git a/oragono.service b/oragono.service
index be13c7576008..811b631712e7 100644
--- a/oragono.service
+++ b/oragono.service
@@ -2,9 +2,8 @@
Description=A modern IRC server written in Go
[Service]
-WorkingDirectory=/opt/oragono
Type=simple
-ExecStart=/opt/oragono/oragono run
+ExecStart=/usr/bin/oragono run --conf /etc/oragono.conf
[Install]
WantedBy=multi-user.target
diff --git a/path.patch b/path.patch
new file mode 100644
index 000000000000..097ce6d67df4
--- /dev/null
+++ b/path.patch
@@ -0,0 +1,41 @@
+--- oragono.yaml 2017-06-26 09:52:22.638430466 -0400
++++ ../../oragono.conf 2017-06-26 09:52:54.349010749 -0400
+@@ -24,8 +24,8 @@
+ tls-listeners:
+ # listener on ":6697"
+ ":6697":
+- key: tls.key
+- cert: tls.crt
++ key: /var/lib/oragono/tls.key
++ cert: /var/lib/oragono/tls.crt
+
+ # strict transport security, to get clients to automagically use TLS
+ sts:
+@@ -62,8 +62,7 @@
+ #password: ""
+
+ # motd filename
+- # if you change the motd, you should move it to ircd.motd
+- motd: oragono.motd
++ motd: /var/lib/oragono/ircd.motd
+
+ # maximum length of clients' sendQ in bytes
+ # this should be big enough to hold /LIST and HELP replies
+@@ -214,7 +213,7 @@
+ method: file stderr
+
+ # filename to log to, if file method is selected
+- filename: ircd.log
++ filename: /var/log/oragono.log
+
+ # type(s) of logs to keep here. you can use - to exclude those types
+ #
+@@ -256,7 +255,7 @@
+ # datastore configuration
+ datastore:
+ # path to the datastore
+- path: ircd.db
++ path: /var/lib/oragono/ircd.db
+
+ # limits - these need to be the same across the network
+ limits: