summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.editorconfig10
-rw-r--r--PKGBUILD6
-rw-r--r--install36
-rw-r--r--path.patch44
5 files changed, 67 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 254d1ee905f2..db312bc4ae4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oragono
pkgdesc = A modern IRC server written in Go.
- pkgver = 2.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/oragono/oragono
install = install
@@ -10,7 +10,7 @@ pkgbase = oragono
makedepends = git
depends = glibc
backup = etc/oragono.conf
- source = git+https://github.com/oragono/oragono#tag=v2.0.0
+ source = git+https://github.com/oragono/oragono#tag=v2.1.0
source = oragono.service
source = oragono.sysusers
source = path.patch
@@ -18,7 +18,7 @@ pkgbase = oragono
sha256sums = SKIP
sha256sums = d35dd5205e3b607ee105a1252677d0607d0c35636ee3e6057275b5f13e555858
sha256sums = 7e214caa8bee053adac26a00a17ed732970e86665cbe31553b1d3d609f0a49b4
- sha256sums = 11d251220beea1637ec9bff6be31d1bb95bfe3a1de4fdae5e3cc5c53cea996fd
+ sha256sums = fc3045b87c98d870d846f1ca9698d543622afbc59360120947c048234c79fc89
sha256sums = 8f6baaa89e9723ac3344a2af201a93f348975537bc748024c0a48b0773f42b1f
pkgname = oragono
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..0ea0cc46c761
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,10 @@
+# http://editorconfig.org
+root = true
+
+[*]
+indent_style = space
+indent_size = 4
+end_of_line = lf
+charset = utf-8
+trim_trailing_whitespace = true
+insert_final_newline = true
diff --git a/PKGBUILD b/PKGBUILD
index db1ccfea30cd..c64b4df346ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sean Enck <enckse@gmail.com>
pkgname=oragono
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="A modern IRC server written in Go."
arch=('x86_64')
@@ -19,13 +19,13 @@ source=("git+$url#tag=v$pkgver"
sha256sums=('SKIP'
'd35dd5205e3b607ee105a1252677d0607d0c35636ee3e6057275b5f13e555858'
'7e214caa8bee053adac26a00a17ed732970e86665cbe31553b1d3d609f0a49b4'
- '11d251220beea1637ec9bff6be31d1bb95bfe3a1de4fdae5e3cc5c53cea996fd'
+ 'fc3045b87c98d870d846f1ca9698d543622afbc59360120947c048234c79fc89'
'8f6baaa89e9723ac3344a2af201a93f348975537bc748024c0a48b0773f42b1f')
backup=('etc/oragono.conf')
prepare() {
cd "${srcdir}/$pkgname"
- patch -p1 < ../path.patch
+ patch < ../path.patch
}
build() {
diff --git a/install b/install
index b2fc3992124d..de78ad3882b8 100644
--- a/install
+++ b/install
@@ -1,12 +1,36 @@
+# Warning: This file has syntactically significant, mixed whitespace.
+# The heredoc bodies are indented with tabs up to the block level.
+# The tabs are for block indentation in the source code.
+# The spaces following the tabs are for indentation of the printed output.
+
post_install() {
if [[ ! -e /var/lib/oragono/ircd.db ]]; then
- cat <<-EOF
- ==> oragono needs to initialize the database and have
- certificates made available prior to use.
+ cat <<-EOF
+ ==> oragono needs to initialize the database and have
+ certificates made available prior to use.
+ EOF
+ mkcert_howto
+ fi
+}
- cd /var/lib/oragono
- sudo -u oragono /usr/bin/oragono mkcerts --conf /etc/oragono.conf
- sudo -u oragono /usr/bin/oragono initdb --conf /etc/oragono.conf
+post_upgrade() {
+ if (( "$(vercmp "$2" 2.1.0)" < 0 )); then
+ cat <<-EOF
+ ==> The tls certificate filenames in the default config have changed.
+ In /var/lib/oragono/:
+ tls.crt -> fullchain.pem
+ tls.key -> privkey.pem
+
+ To generate new self-signed certificates:
EOF
+ mkcert_howto
fi
}
+
+mkcert_howto() {
+ cat <<-EOF
+ cd /var/lib/oragono
+ sudo -u oragono /usr/bin/oragono mkcerts --conf /etc/oragono.conf
+ sudo -u oragono /usr/bin/oragono initdb --conf /etc/oragono.conf
+ EOF
+}
diff --git a/path.patch b/path.patch
index 08f8623ac031..0febd8f33361 100644
--- a/path.patch
+++ b/path.patch
@@ -1,28 +1,28 @@
-From 4f96b050a45a79741fa045499ec172f865142ceb Mon Sep 17 00:00:00 2001
-From: Jason Papakostas <vithos@gmail.com>
-Date: Mon, 9 Mar 2020 06:06:14 -0500
-Subject: [PATCH] config: default paths for arch linux package
-
----
- oragono.yaml | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/oragono.yaml b/oragono.yaml
-index 5733d56..f37d5cc 100644
---- a/oragono.yaml
-+++ b/oragono.yaml
-@@ -28,8 +28,8 @@ server:
+--- oragono.yaml.orig 2020-06-08 16:06:51.204833514 +0200
++++ oragono.yaml 2020-06-08 16:14:16.321358294 +0200
+@@ -50,8 +50,8 @@
# The standard SSL/TLS port for IRC is 6697. This will listen on all interfaces:
":6697":
tls:
-- key: tls.key
-- cert: tls.crt
-+ key: /var/lib/oragono/tls.key
-+ cert: /var/lib/oragono/tls.crt
+- cert: fullchain.pem
+- key: privkey.pem
++ cert: /var/lib/oragono/fullchain.pem
++ key: /var/lib/oragono/privkey.pem
# 'proxy' should typically be false. It's only for Kubernetes-style load
# balancing that does not terminate TLS, but sends an initial PROXY line
# in plaintext.
-@@ -114,7 +114,7 @@ server:
+@@ -70,8 +70,8 @@
+ # ":8097":
+ # websocket: true
+ # tls:
+- # cert: fullchain.pem
+- # key: privkey.pem
++ # cert: /var/lib/oragono/fullchain.pem
++ # key: /var/lib/oragono/privkey.pem
+
+ # sets the permissions for Unix listen sockets. on a typical Linux system,
+ # the default is 0775 or 0755, which prevents other users/groups from connecting
+@@ -154,7 +154,7 @@
# motd filename
# if you change the motd, you should move it to ircd.motd
@@ -31,7 +31,7 @@ index 5733d56..f37d5cc 100644
# motd formatting codes
# if this is true, the motd is escaped using formatting codes like $c, $b, and $i
-@@ -593,7 +593,7 @@ debug:
+@@ -685,7 +685,7 @@
# datastore configuration
datastore:
# path to the datastore
@@ -40,7 +40,7 @@ index 5733d56..f37d5cc 100644
# if the database schema requires an upgrade, `autoupgrade` will attempt to
# perform it automatically on startup. the database will be backed
-@@ -621,7 +621,7 @@ languages:
+@@ -714,7 +714,7 @@
default: en
# which directory contains our language files
@@ -49,5 +49,3 @@ index 5733d56..f37d5cc 100644
# limits - these need to be the same across the network
limits:
---
-2.25.1