summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97b1a5952f9f..f1ffe6dfa5e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = orocos-typelib
pkgdesc = Open Robot Control Software is a tool to create real-time robotics applications using modular, run-time configurable software components (Typelib)
pkgver = 2.6.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.orocos.org/rtt
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9f7a3cbc5c19..51ea37a950df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=orocos-typelib
_pkgname=orocos-toolchain
pkgver=2.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Open Robot Control Software is a tool to create real-time robotics applications using modular, run-time configurable software components (Typelib)"
arch=('i686' 'x86_64')
url="http://www.orocos.org/rtt"
@@ -20,6 +20,11 @@ sha512sums=('7d30ac8bb751c489302cb15c8a613345aabb2023c935c04f371bb35b52faabd9563
build() {
# build typelib
cd "${srcdir}/${_pkgname}-${pkgver}/typelib"
+
+ # patch for for compilation issues in c and ruby binding
+ sed 's#BOOST_STATIC_ASSERT#// BOOST_STATIC_ASSERT#g' -i lang/csupport/containers.cc
+ sed 's#elseif (RUBY_19)#else (RUBY_19)#g' -i cmake/RubyExtensions.cmake
+
cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}