summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD66
-rw-r--r--osirisedit-makefile-flags.patch22
3 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20a1d3c97890
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = osirisedit
+ pkgdesc = A wavetable editor for the Osiris Eurorack synthesizer module.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://www.modbap.com/pages/osirisedit
+ arch = x86_64
+ groups = pro-audio
+ license = GPL3
+ makedepends = git
+ depends = gtk2
+ depends = jansson
+ depends = libsamplerate
+ depends = libsndfile
+ depends = sdl2
+ source = osirisedit::git+https://github.com/switchupcb/OsirisEdit#tag=v1.1.0
+ source = imgui::git+https://github.com/AndrewBelt/imgui.git#commit=cfb1dd6
+ source = lodepng::git+https://github.com/lvandeve/lodepng#commit=8a0f16a
+ source = osdialog::git+https://github.com/AndrewBelt/osdialog#commit=e66caf0
+ source = pffft::git+https://github.com/marton78/pffft#commit=c5062dc
+ source = osirisedit-makefile-flags.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 8b573b67aae5cf0375eede9d85356aef
+
+pkgname = osirisedit
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c2059c0dbc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Daniel Appelt <daniel.appelt@gmail.com>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_reponame=OsirisEdit
+_pkgname="${_reponame,,}"
+pkgname="${_pkgname}"
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A wavetable editor for the Osiris Eurorack synthesizer module."
+arch=('x86_64')
+url="https://www.modbap.com/pages/osirisedit"
+license=('GPL3')
+depends=('gtk2' 'jansson' 'libsamplerate' 'libsndfile' 'sdl2')
+makedepends=('git')
+groups=('pro-audio')
+source=("${_pkgname}::git+https://github.com/switchupcb/${_reponame}#tag=v${pkgver}"
+ 'imgui::git+https://github.com/AndrewBelt/imgui.git#commit=cfb1dd6'
+ 'lodepng::git+https://github.com/lvandeve/lodepng#commit=8a0f16a'
+ 'osdialog::git+https://github.com/AndrewBelt/osdialog#commit=e66caf0'
+ 'pffft::git+https://github.com/marton78/pffft#commit=c5062dc'
+ 'osirisedit-makefile-flags.patch')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '8b573b67aae5cf0375eede9d85356aef')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ git submodule add -f "${srcdir}/imgui" ext/imgui
+ git submodule add -f "${srcdir}/lodepng" ext/lodepng
+ git submodule add -f "${srcdir}/osdialog" ext/osdialog
+ git submodule add -f "${srcdir}/pffft" ext/pffft
+
+ git submodule init
+ git submodule update
+
+ # Fix include and library paths for Linux using system libs
+ patch -p1 -N -r - -i "${srcdir}"/osirisedit-makefile-flags.patch
+ # Patch source for where OsirisEdit looks for images
+ sed -i -E -e 's|([-a-z]+\.png)|/usr/share/'${_pkgname}'/images/\1|' src/ui.cpp
+ # Patch source for where OsirisEdit looks for fonts
+ sed -i -e 's|"fonts/|"/usr/share/'${_pkgname}'/fonts/|' src/ui.cpp
+ # Patch source for where OsirisEdit looks for the manual PDF
+ sed -i -e 's|"manual\.pdf"|"/usr/share/doc/'${_pkgname}'/manual.pdf"|' src/ui.cpp
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -vDm 755 OsirisEdit -t "${pkgdir}"/usr/bin
+ install -vDm 644 logo-*.png -t "${pkgdir}"/usr/share/${_pkgname}/images
+ install -vDm 644 fonts/*.ttf -t "${pkgdir}"/usr/share/${_pkgname}/fonts
+ ln -sf OsirisEdit "${pkgdir}"/usr/bin/osirisedit
+
+ install -vDm644 doc/*.{html,pdf,woff} -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -vDm644 doc/images/*.png -t "${pkgdir}/usr/share/doc/${_pkgname}/images"
+ # used by manual.html, but not really important
+ #install -vDm644 doc/Montserrat/*.ttf -t "${pkgdir}/usr/share/doc/${_pkgname}/Montserrat"
+}
diff --git a/osirisedit-makefile-flags.patch b/osirisedit-makefile-flags.patch
new file mode 100644
index 000000000000..a96a6f01dead
--- /dev/null
+++ b/osirisedit-makefile-flags.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile b/Makefile
+index 2b0de9f..14ee615 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,11 +22,14 @@ SOURCES = \
+ include Makefile-arch.inc
+ ifeq ($(ARCH),lin)
+ # Linux
+- FLAGS += -DARCH_LIN $(shell pkg-config --cflags gtk+-2.0)
++ FLAGS += -DARCH_LIN \
++ $(shell pkg-config --cflags gtk+-2.0) \
++ $(shell pkg-config --cflags sdl2)
+ LDFLAGS += -static-libstdc++ -static-libgcc \
+ -lGL -lpthread \
+- -Ldep/lib -lSDL2 -lsamplerate -lsndfile -ljansson -lcurl \
+- -lgtk-x11-2.0 -lgobject-2.0
++ -Ldep/lib -lsamplerate -lsndfile -ljansson -lcurl \
++ $(shell pkg-config --libs sdl2) \
++ $(shell pkg-config --libs gtk+-2.0)
+ SOURCES += ext/osdialog/osdialog_gtk2.c
+ else ifeq ($(ARCH),mac)
+ # Mac