summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9925fc604111
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = osux-visual
+ pkgdesc = GUI tools based on osux-lib
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/tomtix/osux-visual/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = glib2
+ depends = gtk3
+ depends = gstreamer
+ depends = osux
+ source = https://github.com/tomtix/osux-visual/archive/v0.1.tar.gz
+ md5sums = 36fdeaf06cf2788f9eb01b780ac6b340
+
+pkgname = osux-visual
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2aaded1ceb82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#maintainer: Thomas Mijieux < thomas dot mijieux at hotmail dot fr >
+pkgname=osux-visual
+pkgver=0.1
+pkgrel=1
+pkgdesc="GUI tools based on osux-lib"
+arch=('i686' 'x86_64')
+url="https://github.com/tomtix/osux-visual/"
+license=("Apache")
+depends=('glib2' 'gtk3' 'gstreamer' 'osux')
+source=("https://github.com/tomtix/osux-visual/archive/v$pkgver.tar.gz")
+md5sums=('36fdeaf06cf2788f9eb01b780ac6b340')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ make DESTDIR="$pkgdir" install
+}