summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a4f2608ba8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = otf-clara
+ pkgdesc = A a serif font family created specially for printing A Dictionary of Editing (2015)
+ pkgver = 1
+ pkgrel = 1
+ url = https://fontesk.com/clara-typeface/
+ arch = any
+ license = custom:SIL Open Font License v1.1
+ source = otf-clara-1.zip::https://fontesk.com/download/33540/
+ sha256sums = 67c0e3208aa3418a37aef69446ca0ca4de29d9a985d6cdeca1d55a88c2d55001
+
+pkgname = otf-clara
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..77dc710e0c7e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+*.zip
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c15782ce5ebd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Agatha Zeren <agatha@zeren.com>
+
+pkgname=otf-clara
+pkgver=1
+pkgrel=1
+pkgdesc='A a serif font family created specially for printing A Dictionary of Editing (2015)'
+arch=('any')
+url='https://fontesk.com/clara-typeface/'
+license=('custom:SIL Open Font License v1.1')
+source=("${pkgname}-${pkgver}.zip::https://fontesk.com/download/33540/")
+sha256sums=('67c0e3208aa3418a37aef69446ca0ca4de29d9a985d6cdeca1d55a88c2d55001')
+
+package() {
+ cd $srcdir
+ echo opentype/*.otf
+ install -Dm644 -t "${pkgdir}/usr/share/fonts/OTF" opentype/*.otf
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/$pkgname" "doc/COPYING"
+}