summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a95cbe97882a..2a34652cb053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = otf-gfs-neohellenic-math
pkgdesc = An open type mathematical font from the Greek Font Society.
- pkgver = 20190727
+ pkgver = 20220713
pkgrel = 1
- url = http://www.greekfontsociety-gfs.gr
+ url = https://www.greekfontsociety-gfs.gr
arch = any
license = custom: SIL-OFL
makedepends = unzip
noextract = GFS_NeoHellenic_Math.zip
noextract = LICENSE
- source = http://www.greekfontsociety-gfs.gr/_assets/fonts/GFS_NeoHellenic_Math.zip
+ source = https://www.greekfontsociety-gfs.gr/_assets/fonts/GFS_NeoHellenic_Math.zip
source = LICENSE
- md5sums = aac8f8ba1606c8a110bba93688495d04
- md5sums = 288069c8fb0c828b081833cfcfe0638b
+ sha512sums = 75168c5a0da5a123aa6c6dc8283b13d04ddace96ec594b057534a37f942aa334d08b8957cc8d879a77332c486556df04eb7f9f944bf0b338c8990a27de93096a
+ sha512sums = 9583e535c20621e989455cc76e97d7c71b7c592dc02036309e228ccdee1b0d56067bbf367ab414fcf20a428d05e7a9149851b46b5f6d6637b86f29c3ecf7629e
pkgname = otf-gfs-neohellenic-math
-
diff --git a/PKGBUILD b/PKGBUILD
index c43d4d13977a..7ec1ca6939bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: GordonGR <ntheo1979@gmail.com>
pkgname=otf-gfs-neohellenic-math
-pkgver=20190727
+pkgver=20220713
pkgrel=1
pkgdesc='An open type mathematical font from the Greek Font Society.'
arch=(any)
-url='http://www.greekfontsociety-gfs.gr'
+url="https://www.greekfontsociety-gfs.gr"
license=('custom: SIL-OFL')
-makedepends=('unzip')
depends=()
-
-source=("http://www.greekfontsociety-gfs.gr/_assets/fonts/GFS_NeoHellenic_Math.zip"
- "LICENSE")
+makedepends=('unzip')
+source=("${url}/_assets/fonts/GFS_NeoHellenic_Math.zip"
+ "LICENSE")
noextract=(${source[@]##*/})
-md5sums=('aac8f8ba1606c8a110bba93688495d04'
- '288069c8fb0c828b081833cfcfe0638b')
+sha512sums=('75168c5a0da5a123aa6c6dc8283b13d04ddace96ec594b057534a37f942aa334d08b8957cc8d879a77332c486556df04eb7f9f944bf0b338c8990a27de93096a'
+ '9583e535c20621e989455cc76e97d7c71b7c592dc02036309e228ccdee1b0d56067bbf367ab414fcf20a428d05e7a9149851b46b5f6d6637b86f29c3ecf7629e')
package() {
-cd "$srcdir"
-_xlist="__MACOSX/* .OFL-FAQ.txt OFL-FAQ.txt OFL.txt"
-unzip GFS_NeoHellenic_Math.zip -x ${_xlist}
+ _xlist="README *.sty *.pdf"
+ unzip GFS_NeoHellenic_Math.zip -x ${_xlist}
-install -d $pkgdir/usr/share/fonts/$pkgname/
-install -Dm644 $srcdir/GFS*/*otf $pkgdir/usr/share/fonts/$pkgname/
-install -d $pkgdir/usr/share/licenses/$pkgname/
-install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -d ${pkgdir}/usr/share/fonts/${pkgname}
+ install -Dm 644 GFS*/*otf ${pkgdir}/usr/share/fonts/${pkgname}
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}