summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--otf-yanone-kaffeesatz.install13
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..736978ff7d7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-yanone-kaffeesatz
+ pkgdesc = The free OpenType Yanone Kaffeesatz font
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.yanone.de/typedesign/kaffeesatz/
+ install = otf-yanone-kaffeesatz.install
+ arch = any
+ license = Creative Commons
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://www.yanone.de/2015/data/UIdownloads/Yanone%20Kaffeesatz.zip
+ md5sums = e1bb666675f715e0c01ceb086a7784cb
+
+pkgname = otf-yanone-kaffeesatz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e09253c3f3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Pau Ruiz Safont <unduthegun at gmail dot com>
+
+pkgname=otf-yanone-kaffeesatz
+pkgver=1.0
+pkgrel=1
+depends=('fontconfig' 'xorg-font-utils')
+pkgdesc="The free OpenType Yanone Kaffeesatz font"
+arch=('any')
+url='http://www.yanone.de/typedesign/kaffeesatz/'
+license=('Creative Commons')
+install=${pkgname}.install
+source=('https://www.yanone.de/2015/data/UIdownloads/Yanone%20Kaffeesatz.zip')
+md5sums=('e1bb666675f715e0c01ceb086a7784cb')
+
+package()
+{
+ cd ${srcdir}
+ install -d ${pkgdir}/usr/share/fonts/OTF
+ install -m644 *.otf ${pkgdir}/usr/share/fonts/OTF/
+}
+
+
diff --git a/otf-yanone-kaffeesatz.install b/otf-yanone-kaffeesatz.install
new file mode 100644
index 000000000000..4b77955a6a4f
--- /dev/null
+++ b/otf-yanone-kaffeesatz.install
@@ -0,0 +1,13 @@
+post_install()
+{
+ echo -n "Updating font cache..."
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade()
+{
+ post_install
+}