summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f5b5e173eb2..21b692815e1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ouch-git
pkgdesc = Painless compression and decompression in the terminal (git version)
- pkgver = r397.abf1d4e
+ pkgver = r693.d4f181b
pkgrel = 1
url = https://github.com/ouch-org/ouch/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8e036cec16a8..7a33f12663c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ouch-git
_pkgname=${pkgname%-git}
-pkgver=r397.abf1d4e
+pkgver=r693.d4f181b
pkgrel=1
pkgdesc="Painless compression and decompression in the terminal (git version)"
arch=('x86_64')
@@ -28,7 +28,7 @@ build() {
cd "$srcdir/${_pkgname}"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- GEN_COMPLETIONS=1 cargo build --frozen --release --all-features
+ OUCH_ARTIFACTS_FOLDER=artifacts cargo build --frozen --release --all-features
}
check() {
@@ -39,13 +39,20 @@ check() {
package() {
cd "$srcdir/${_pkgname}"
+
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname}"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
- cd target/release/build/ouch-*/out/completions
- sed -i "s/':output -- The resulting file. It's extensions can be used to specify the compression formats:_files'/\":output -- The resulting file. It's extensions can be used to specify the compression formats:_files\"/" _ouch
+ cd artifacts
+
+ # install manpages
+ install -Dm0644 "${_pkgname}.1" -t "${pkgdir}/usr/share/man/man1"
+ install -Dm0644 "${_pkgname}-compress.1" -t "${pkgdir}/usr/share/man/man1"
+ install -Dm0644 "${_pkgname}-decompress.1" -t "${pkgdir}/usr/share/man/man1"
+ install -Dm0644 "${_pkgname}-list.1" -t "${pkgdir}/usr/share/man/man1"
- install -Dm0644 ${_pkgname}.bash "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
- install -Dm0644 ${_pkgname}.fish "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
- install -Dm0644 _${_pkgname} "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
+ # install shell completions
+ install -Dm0644 "${_pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
+ install -Dm0644 "${_pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${_pkgname}.fish"
+ install -Dm0644 "_${_pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${_pkgname}"
}