summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD44
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..965824b0269c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = overplay-vpn
+ pkgdesc = Certificate and connection files for connecting to Overplay VPN servers using OpenVPN
+ pkgver = 1.0
+ pkgrel = 2
+ url = https://www.overplay.net/setup.php
+ arch = any
+ license = custom
+ makedepends = coreutils
+ depends = openvpn
+ source = https://patch.oppatch.com/OverplayCert.crt
+ source = https://patch.oppatch.com/connections.zip
+ source = LICENSE
+ md5sums = edcf0a2cd555712d68384a3e3b9958e8
+ md5sums = 4968f6b9b737c59ce70b38f6ef7cec33
+ md5sums = 8e6266c7807425a36a4d417a88a3cd53
+
+pkgname = overplay-vpn
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ec9707a33302
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,3 @@
+Overplay Terms of Service:
+
+https://www.overplay.net/terms.php
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11a6942e99ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Pantelis Panayiotou <p.panayiotou@gmail.com>
+pkgname=overplay-vpn
+pkgver=1.0
+pkgrel=2
+epoch=
+pkgdesc="Certificate and connection files for connecting to Overplay VPN servers using OpenVPN"
+arch=('any')
+url="https://www.overplay.net/setup.php"
+license=('custom')
+groups=()
+depends=('openvpn')
+makedepends=('coreutils')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+source=('https://patch.oppatch.com/OverplayCert.crt' 'https://patch.oppatch.com/connections.zip' 'LICENSE')
+noextract=()
+md5sums=('edcf0a2cd555712d68384a3e3b9958e8' '4968f6b9b737c59ce70b38f6ef7cec33' '8e6266c7807425a36a4d417a88a3cd53')
+
+build() {
+ cd "${srcdir}"
+ for i in *.conf
+ do
+ sed -e 's/OverplayCert.crt/\/etc\/openvpn\/OverplayCert.crt/g' -i "${i}"
+ done
+}
+
+package() {
+ cd "$srcdir/"
+
+ install -D -m 666 OverplayCert.crt ${pkgdir}/etc/openvpn/OverplayCert.crt
+ for i in *.conf
+ do
+ install -D -m 666 "${i}" "${pkgdir}/etc/openvpn/${i}"
+ done
+ install -D -m 666 LICENSE ${pkgdir}/usr/share/licenses/overplay-vpn/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: