summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--makefile.patch30
3 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df93debf0256..ec88c42fae4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pachi
pkgdesc = A reasonably strong engine for the board game go
- pkgver = 12.82
+ pkgver = 12.84
pkgrel = 1
url = http://pachi.or.cz/
arch = i686
@@ -8,9 +8,9 @@ pkgbase = pachi
license = GPL
depends = glibc
options = !makeflags
- source = https://github.com/pasky/pachi/archive/pachi-12.82.tar.gz
+ source = https://github.com/pasky/pachi/archive/pachi-12.84.tar.gz
source = makefile.patch
- sha256sums = 1920c3f58b07cb50f7dc38d52485a26990279343119225c6302768840047f507
- sha256sums = 3a9d02d554f217c245dcae78d181acd99b35b58f22b66248b7768a2eab9dd0dd
+ sha256sums = 5ced9ffd9fdb0ee4cdb24ad341abbcb7df0ab8a7f244932b7dd3bfa0ff6180ba
+ sha256sums = e2cfd2bf317494e602e52075f2577b904c3fcf0ec359556b5f74f4cc17d322ae
pkgname = pachi
diff --git a/PKGBUILD b/PKGBUILD
index 0eb48810ba48..9fe5d1eb1ef4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=pachi
-pkgver=12.82
+pkgver=12.84
pkgrel=1
pkgdesc="A reasonably strong engine for the board game go"
arch=('i686' 'x86_64')
@@ -10,8 +10,8 @@ depends=('glibc')
url="http://pachi.or.cz/"
license=('GPL')
source=("https://github.com/pasky/pachi/archive/$pkgname-$pkgver.tar.gz" makefile.patch)
-sha256sums=('1920c3f58b07cb50f7dc38d52485a26990279343119225c6302768840047f507'
- '3a9d02d554f217c245dcae78d181acd99b35b58f22b66248b7768a2eab9dd0dd')
+sha256sums=('5ced9ffd9fdb0ee4cdb24ad341abbcb7df0ab8a7f244932b7dd3bfa0ff6180ba'
+ 'e2cfd2bf317494e602e52075f2577b904c3fcf0ec359556b5f74f4cc17d322ae')
options=('!makeflags')
prepare() {
diff --git a/makefile.patch b/makefile.patch
index 3edf8a3f7307..e4f3b11e078b 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,5 +1,12 @@
---- pachi-pachi-12.82/Makefile 2023-07-05 04:25:05.000000000 +0200
-+++ pachi-pachi-12.82.new/Makefile 2023-08-18 23:50:06.538581419 +0200
+diff -urN pachi-pachi-12.84/build.init pachi-pachi-12.84.new/build.init
+--- pachi-pachi-12.84/build.init 1970-01-01 01:00:00.000000000 +0100
++++ pachi-pachi-12.84.new/build.init 2024-01-11 19:22:56.505188320 +0100
+@@ -0,0 +1,2 @@
++#define PACHI_GIT_BRANCH ""
++#define PACHI_GIT_HASH ""
+diff -urN pachi-pachi-12.84/Makefile pachi-pachi-12.84.new/Makefile
+--- pachi-pachi-12.84/Makefile 2023-09-10 17:28:22.000000000 +0200
++++ pachi-pachi-12.84.new/Makefile 2024-01-11 19:23:53.467794008 +0100
@@ -207,6 +207,7 @@
ifeq ($(DCNN_DETLEF), 1)
@@ -13,16 +20,25 @@
# Low-level dependencies last
SUBDIRS = $(EXTRA_SUBDIRS) pattern joseki uct uct/policy t-unit t-predict engines playout tactics
-DATAFILES = $(EXTRA_DATAFILES) detlef54.prototxt detlef54.trained joseki19.gtp opening.dat patterns_mm.gamma patterns_mm.spat
-+DATAFILES = $(EXTRA_DATAFILES) joseki19.gtp patterns_mm.gamma patterns_mm.spat
++DATAFILES = $(EXTRA_DATAFILES) joseki19.gtp patterns_mm.gamma patterns_mm.spat
############################################################################################################
-@@ -310,7 +311,7 @@
+@@ -310,15 +311,12 @@
@CC="$(CC)" CFLAGS="$(CFLAGS)" ./spudfrog
# Build info
--build.h: .git/HEAD .git/index Makefile
-+build.h: Makefile
+-build.h: build.h.git Makefile
++build.h: build.init Makefile
+@make spudfrog
@echo "[make] build.h"
- @CC="$(CC)" CFLAGS="$(CFLAGS)" ./genbuild > $@
+- @cp build.h.git $@
++ @cp build.init $@
+ @CC="$(CC)" CFLAGS="$(CFLAGS)" ./genbuild >> $@
+
+-build.h.git: .git/HEAD .git/index
+- @./genbuild --git > $@
+-
+ # Unit tests
+ test: FORCE
+ +@make -C t-unit test