summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD129
-rw-r--r--add-flto-to-LDFLAGS-for-clang.patch24
-rw-r--r--libmakepkg-add-extra-buildflags-only-when-buildflags.patch41
-rw-r--r--make-link-time-optimization-flags-configurable.patch108
-rw-r--r--makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch40
-rw-r--r--makepkg.conf23
-rw-r--r--pacman.conf (renamed from pacman.conf.x86_64)2
-rw-r--r--pacman.conf.arm91
-rw-r--r--pacman.conf.i68691
10 files changed, 290 insertions, 302 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cc93f154781..69c10d777397 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,46 +1,45 @@
pkgbase = pacman-hearts
- pkgdesc = A library-based package manager with dependency support
- pkgver = 6.0.0
+ pkgdesc = A library-based package manager with dependency support. With hearts in progress bar!
+ pkgver = 6.0.1
pkgrel = 1
url = https://www.archlinux.org/pacman/
- arch = i686
arch = x86_64
- arch = arm
- arch = armv6h
- arch = armv7h
- arch = aarch64
+ groups = base-devel
license = GPL
checkdepends = python
checkdepends = fakechroot
- makedepends = git
+ makedepends = meson
makedepends = asciidoc
makedepends = doxygen
- makedepends = meson
- depends = archlinux-keyring
depends = bash
+ depends = glibc
+ depends = libarchive
depends = curl
depends = gpgme
- depends = libarchive
depends = pacman-mirrorlist
- optdepends = pacman-contrib: various helper utilities
+ depends = archlinux-keyring
optdepends = perl-locale-gettext: translation support in makepkg-template
provides = pacman=6
conflicts = pacman
- options = emptydirs
options = strip
+ options = debug
backup = etc/pacman.conf
backup = etc/makepkg.conf
- source = https://gitlab.archlinux.org/pacman/pacman/-/archive/v6.0.0/pacman-v6.0.0.tar.gz
- source = pacman.conf.i686
- source = pacman.conf.x86_64
- source = pacman.conf.arm
+ source = https://sources.archlinux.org/other/pacman/pacman-6.0.1.tar.xz
+ source = add-flto-to-LDFLAGS-for-clang.patch
+ source = makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch
+ source = libmakepkg-add-extra-buildflags-only-when-buildflags.patch
+ source = make-link-time-optimization-flags-configurable.patch
+ source = pacman.conf
source = makepkg.conf
source = pacman-hearts.patch
- sha256sums = 4c3be330bd285d4c6d6a2f82efba526f85a61a84cd7689ceaac48f571cb6e88f
- sha256sums = 0e09eb240512da85f7eaa314a5a98fe7d4c4e7ed5eebde7e3e937c0ae4ee7054
- sha256sums = 7ff75a61a07eabbc1718a7171b897b6504a6370f2f59a14caf42bbf0dce26ea6
- sha256sums = 3fa640a4a2138b8d07b6e6366ff0743206ecb32fc3b7f53490a614388c492cf3
- sha256sums = 0c1ecbb8c57e8ef2c600b41d4458269095fc4ddb6778d0000d4a9a067f68fe2d
+ sha256sums = 0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731
+ sha256sums = 82ff91b85f4c6ceba19f9330437e2a22aabc966c2b9e2a20a53857f98a42c223
+ sha256sums = b940e6c0c05a185dce1dbb9da0dcbebf742fca7a63f3e3308d49205afe5a6582
+ sha256sums = 7d0aee976c9c71fcf7c96ef1d99aa76efe47d8c1f4451842d6d159ec7deb4278
+ sha256sums = 5b43e26a76be3ed10a69d4bfb2be48db8cce359baf46583411c7f124737ebe6a
+ sha256sums = 606e55f06c297d2b508bc4438890b229a1abaa68b0374a2d7f94c8e7be6792d7
+ sha256sums = 072020e34f2c55b94a9a486829a7eadab0a830ddb4d8e759b0c4e6cf1bde73a6
sha256sums = d4c929334e5eac1be05673338ecefb493ec3735cd3cd3e4be2eb8dfe585677e1
pkgname = pacman-hearts
diff --git a/PKGBUILD b/PKGBUILD
index 82c4ade0e7bf..afaebb0c76e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,121 +1,78 @@
-# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
-# Contributor: Dave Reisner <d@falconindy.com>
-# Contributor: Thomas Dziedzic < gostrc at gmail >
-# Contributor: godane <slaxemulator@gmail.com.com>
-# Contributor: Andres Perera <aepd87@gmail.com>
+# vim: set ts=2 sw=2 et:
+# Maintainer:
pkgname=pacman-hearts
_pkgname=pacman
-pkgver=6.0.0
+pkgver=6.0.1
pkgrel=1
-pkgdesc="A library-based package manager with dependency support"
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+pkgdesc="A library-based package manager with dependency support. With hearts in progress bar!"
+arch=('x86_64')
url="https://www.archlinux.org/pacman/"
license=('GPL')
-depends=('archlinux-keyring' 'bash' 'curl' 'gpgme' 'libarchive'
- 'pacman-mirrorlist')
-optdepends=('pacman-contrib: various helper utilities'
- 'perl-locale-gettext: translation support in makepkg-template')
-makedepends=('git' 'asciidoc' 'doxygen' 'meson')
+groups=('base-devel')
+depends=('bash' 'glibc' 'libarchive' 'curl'
+ 'gpgme' 'pacman-mirrorlist' 'archlinux-keyring')
+makedepends=('meson' 'asciidoc' 'doxygen')
checkdepends=('python' 'fakechroot')
+optdepends=('perl-locale-gettext: translation support in makepkg-template')
provides=("pacman=${pkgver%.*.*}")
conflicts=('pacman')
-backup=("etc/pacman.conf"
- "etc/makepkg.conf")
-options=('emptydirs' 'strip')
-source=("https://gitlab.archlinux.org/pacman/pacman/-/archive/v6.0.0/pacman-v6.0.0.tar.gz"
- "pacman.conf.i686"
- "pacman.conf.x86_64"
- "pacman.conf.arm"
- "makepkg.conf"
- "pacman-hearts.patch")
-sha256sums=('4c3be330bd285d4c6d6a2f82efba526f85a61a84cd7689ceaac48f571cb6e88f'
- '0e09eb240512da85f7eaa314a5a98fe7d4c4e7ed5eebde7e3e937c0ae4ee7054'
- '7ff75a61a07eabbc1718a7171b897b6504a6370f2f59a14caf42bbf0dce26ea6'
- '3fa640a4a2138b8d07b6e6366ff0743206ecb32fc3b7f53490a614388c492cf3'
- '0c1ecbb8c57e8ef2c600b41d4458269095fc4ddb6778d0000d4a9a067f68fe2d'
+backup=(etc/pacman.conf
+ etc/makepkg.conf)
+options=('strip' 'debug')
+source=(https://sources.archlinux.org/other/pacman/$_pkgname-$pkgver.tar.xz
+ add-flto-to-LDFLAGS-for-clang.patch
+ makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch
+ libmakepkg-add-extra-buildflags-only-when-buildflags.patch
+ make-link-time-optimization-flags-configurable.patch
+ pacman.conf
+ makepkg.conf
+ pacman-hearts.patch)
+sha256sums=('0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731'
+ '82ff91b85f4c6ceba19f9330437e2a22aabc966c2b9e2a20a53857f98a42c223'
+ 'b940e6c0c05a185dce1dbb9da0dcbebf742fca7a63f3e3308d49205afe5a6582'
+ '7d0aee976c9c71fcf7c96ef1d99aa76efe47d8c1f4451842d6d159ec7deb4278'
+ '5b43e26a76be3ed10a69d4bfb2be48db8cce359baf46583411c7f124737ebe6a'
+ '606e55f06c297d2b508bc4438890b229a1abaa68b0374a2d7f94c8e7be6792d7'
+ '072020e34f2c55b94a9a486829a7eadab0a830ddb4d8e759b0c4e6cf1bde73a6'
'd4c929334e5eac1be05673338ecefb493ec3735cd3cd3e4be2eb8dfe585677e1')
prepare() {
- cd "$_pkgname-v$pkgver"
- patch -p1 -i "$srcdir"/pacman-hearts.patch
+ cd "$_pkgname-$pkgver"
+ patch -Np1 -i ../add-flto-to-LDFLAGS-for-clang.patch
+ patch -Np1 -i ../makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch
+ patch -Np1 -i ../libmakepkg-add-extra-buildflags-only-when-buildflags.patch
+ patch -Np1 -i ../make-link-time-optimization-flags-configurable.patch
+ patch -Np1 -i "$srcdir"/pacman-hearts.patch
}
build() {
- mkdir -p "$_pkgname-v$pkgver/build"
- cd "$_pkgname-v$pkgver/build"
+ cd "$_pkgname-$pkgver"
meson --prefix=/usr \
--buildtype=plain \
-Ddoc=enabled \
-Ddoxygen=enabled \
- -Duse-git-version=true \
-Dscriptlet-shell=/usr/bin/bash \
-Dldconfig=/usr/bin/ldconfig \
- ..
- ninja
+ build
+
+ meson compile -C build
}
check() {
- cd "$_pkgname-v$pkgver/build"
+ cd "$_pkgname-$pkgver"
- ninja test
+ meson test -C build
}
package() {
- cd "$_pkgname-v$pkgver/build"
+ cd "$_pkgname-$pkgver"
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" meson install -C build
# install Arch specific stuff
install -dm755 "$pkgdir/etc"
- if [[ $CARCH =~ arm* || $CARCH = aarch64 ]]; then
- # $CARCH != uname -m
- sed -e "s|@CARCH[@]|$CARCH|g" "$srcdir/pacman.conf.arm" \
- | install -m644 /dev/stdin "$pkgdir/etc/pacman.conf"
- else
- install -m644 "$srcdir/pacman.conf.$CARCH" "$pkgdir/etc/pacman.conf"
- fi
-
- # set things correctly in the default conf file
- local mychost myflags moresed=()
- case $CARCH in
- i686)
- mychost="i686-pc-linux-gnu"
- myflags="-march=i686"
- ;;
- x86_64)
- mychost="x86_64-pc-linux-gnu"
- myflags="-march=x86-64"
- ;;
- arm*|aarch64)
- moresed+=('-e' 's/-fcf-protection//')
- ;;&
- arm)
- mychost="armv5tel-unknown-linux-gnueabi"
- myflags="-march=armv5te"
- ;;
- armv6h)
- mychost="armv6l-unknown-linux-gnueabihf"
- myflags="-march=armv6 -mfloat-abi=hard -mfpu=vfp"
- ;;
- armv7h)
- mychost="armv7l-unknown-linux-gnueabihf"
- myflags="-march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16"
- ;;
- aarch64)
- mychost="aarch64-unknown-linux-gnu"
- myflags="-march=armv8-a"
- ;;
- esac
-
- # set things correctly in the default conf file
+ install -m644 "$srcdir/pacman.conf" "$pkgdir/etc"
install -m644 "$srcdir/makepkg.conf" "$pkgdir/etc"
- sed -i "$pkgdir/etc/makepkg.conf" \
- -e "s|@CARCH[@]|$CARCH|g" \
- -e "s|@CHOST[@]|$mychost|g" \
- -e "s|@CARCHFLAGS[@]|$myflags|g" \
- "${moresed[@]}"
}
-
-# vim: set ts=2 sw=2 et:
diff --git a/add-flto-to-LDFLAGS-for-clang.patch b/add-flto-to-LDFLAGS-for-clang.patch
new file mode 100644
index 000000000000..b3c139de4d3c
--- /dev/null
+++ b/add-flto-to-LDFLAGS-for-clang.patch
@@ -0,0 +1,24 @@
+From 26ee6ff6adbcd8560ec3a65cf219d2ab98edb804 Mon Sep 17 00:00:00 2001
+From: Allan McRae <allan@archlinux.org>
+Date: Fri, 24 Dec 2021 17:59:32 +1000
+Subject: [PATCH] LTO: Add -flto to LDFLAGS for clang
+
+GCC automatically detects when it is linking LTO objects, but clang does
+not. Add -flto to LDFLAGS to make this work for clang too.
+
+Signed-off-by: Allan McRae <allan@archlinux.org>
+---
+ scripts/libmakepkg/buildenv/lto.sh.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/scripts/libmakepkg/buildenv/lto.sh.in b/scripts/libmakepkg/buildenv/lto.sh.in
+index 1f1ca53f..c3bd0fa4 100644
+--- a/scripts/libmakepkg/buildenv/lto.sh.in
++++ b/scripts/libmakepkg/buildenv/lto.sh.in
+@@ -33,5 +33,6 @@ buildenv_lto() {
+ if check_option "lto" "y"; then
+ CFLAGS+=" -flto"
+ CXXFLAGS+=" -flto"
++ LDFLAGS+=" -flto"
+ fi
+ }
diff --git a/libmakepkg-add-extra-buildflags-only-when-buildflags.patch b/libmakepkg-add-extra-buildflags-only-when-buildflags.patch
new file mode 100644
index 000000000000..365993571147
--- /dev/null
+++ b/libmakepkg-add-extra-buildflags-only-when-buildflags.patch
@@ -0,0 +1,41 @@
+From 42fe4864a0c8e2846007ffee532fe0cf4b321cdd Mon Sep 17 00:00:00 2001
+From: Allan McRae <allan@archlinux.org>
+Date: Sun, 9 Jan 2022 12:45:58 +1000
+Subject: [PATCH] libmakepkg: add extra buildflags only when buildflags is not
+ disabled
+
+This means options=('!buildflags') will disable the addition of CFLAG
+etc for LTO and debug building.
+
+Signed-off-by: Allan McRae <allan@archlinux.org>
+---
+ scripts/libmakepkg/buildenv/debugflags.sh.in | 2 +-
+ scripts/libmakepkg/buildenv/lto.sh.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/scripts/libmakepkg/buildenv/debugflags.sh.in b/scripts/libmakepkg/buildenv/debugflags.sh.in
+index 84ca7b71..1cb58613 100644
+--- a/scripts/libmakepkg/buildenv/debugflags.sh.in
++++ b/scripts/libmakepkg/buildenv/debugflags.sh.in
+@@ -29,7 +29,7 @@ source "$LIBRARY/util/option.sh"
+ buildenv_functions+=('buildenv_debugflags')
+
+ buildenv_debugflags() {
+- if check_option "debug" "y"; then
++ if check_option "debug" "y" && ! check_option "buildflags" "n"; then
+ DEBUG_CFLAGS+=" -ffile-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
+ DEBUG_CXXFLAGS+=" -ffile-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
+ DEBUG_RUSTFLAGS+=" --remap-path-prefix=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
+diff --git a/scripts/libmakepkg/buildenv/lto.sh.in b/scripts/libmakepkg/buildenv/lto.sh.in
+index 081d5648..6e500eab 100644
+--- a/scripts/libmakepkg/buildenv/lto.sh.in
++++ b/scripts/libmakepkg/buildenv/lto.sh.in
+@@ -30,7 +30,7 @@ build_options+=('lto')
+ buildenv_functions+=('buildenv_lto')
+
+ buildenv_lto() {
+- if check_option "lto" "y"; then
++ if check_option "lto" "y" && ! check_option "buildflags" "n"; then
+ CFLAGS+=" -flto"
+ CXXFLAGS+=" -flto"
+ LDFLAGS+=" -flto"
diff --git a/make-link-time-optimization-flags-configurable.patch b/make-link-time-optimization-flags-configurable.patch
new file mode 100644
index 000000000000..1406b7b49937
--- /dev/null
+++ b/make-link-time-optimization-flags-configurable.patch
@@ -0,0 +1,108 @@
+From e1ce2351f5c00dd90104e0f4ce3bf176da28af08 Mon Sep 17 00:00:00 2001
+From: Evangelos Foutras <evangelos@foutrelis.com>
+Date: Thu, 10 Feb 2022 05:15:01 +0200
+Subject: [PATCH] Make link time optimization flags configurable
+
+We want to use -flto=auto in Arch Linux to speed up building, but we
+can't hardcode it in buildenv/lto.sh because other downstreams might
+have clang < 13.0.0 which did not recognize -flto=auto as equivalent
+to -flto=full.
+
+Introducing an LTOFLAGS variable to makepkg.conf seems the way to go.
+
+Signed-off-by: Allan McRae <allan@archlinux.org>
+---
+ doc/makepkg.conf.5.asciidoc | 10 ++++++++--
+ etc/makepkg.conf.in | 1 +
+ scripts/libmakepkg/buildenv/buildflags.sh.in | 2 +-
+ scripts/libmakepkg/buildenv/lto.sh.in | 6 +++---
+ scripts/libmakepkg/lint_config/variable.sh.in | 8 ++++----
+ 5 files changed, 17 insertions(+), 10 deletions(-)
+
+diff --git a/doc/makepkg.conf.5.asciidoc b/doc/makepkg.conf.5.asciidoc
+index 39c5c808..a0d9a6d4 100644
+--- a/doc/makepkg.conf.5.asciidoc
++++ b/doc/makepkg.conf.5.asciidoc
+@@ -81,6 +81,11 @@ Options
+ usage resembling ``-Wl,--hash-style=gnu''. Read ld(1) for more details on
+ available linker flags.
+
++**LTOFLAGS=**"ltoflags"::
++ Additional compiler and linker flags appended to `CFLAGS`, `CXXFLAGS`
++ and `LDFLAGS` when building with link time optimization. If empty,
++ ``-flto'' is used.
++
+ **MAKEFLAGS=**"makeflags"::
+ This is often used to set the number of jobs used; for example, `-j2`.
+ Other flags that make accepts can also be passed.
+@@ -190,8 +195,9 @@ Options
+ package containing the debug symbols when used with `strip'.
+
+ *lto*;;
+- Enable building packages using link time optimization. Adds '-flto'
+- to both CFLAGS and CXXFLAGS.
++ Enable building packages using link time optimization. Adds the
++ flags specified in LTOFLAGS to CFLAGS, CXXFLAGS and LDFLAGS (or
++ ``-flto'' if LTOFLAGS is empty).
+
+ *autodep*;;
+ Enable the automatic addition of libraries to the depends and
+diff --git a/etc/makepkg.conf.in b/etc/makepkg.conf.in
+index 0c911cce..edc5f442 100644
+--- a/etc/makepkg.conf.in
++++ b/etc/makepkg.conf.in
+@@ -41,6 +41,7 @@ CHOST="@CHOST@"
+ #CFLAGS="-O2 -pipe"
+ #CXXFLAGS="-O2 -pipe"
+ #LDFLAGS=""
++#LTOFLAGS="-flto"
+ #RUSTFLAGS="-C opt-level=2"
+ #-- Make Flags: change this for DistCC/SMP systems
+ #MAKEFLAGS="-j2"
+diff --git a/scripts/libmakepkg/buildenv/buildflags.sh.in b/scripts/libmakepkg/buildenv/buildflags.sh.in
+index 74f91988..07b4a730 100644
+--- a/scripts/libmakepkg/buildenv/buildflags.sh.in
++++ b/scripts/libmakepkg/buildenv/buildflags.sh.in
+@@ -30,6 +30,6 @@ buildenv_functions+=('buildenv_buildflags')
+
+ buildenv_buildflags() {
+ if check_option "buildflags" "n"; then
+- unset CPPFLAGS CFLAGS DEBUG_CFLAGS CXXFLAGS DEBUG_CXXFLAGS LDFLAGS RUSTFLAGS DEBUG_RUSTFLAGS
++ unset CPPFLAGS CFLAGS DEBUG_CFLAGS CXXFLAGS DEBUG_CXXFLAGS LDFLAGS LTOFLAGS RUSTFLAGS DEBUG_RUSTFLAGS
+ fi
+ }
+diff --git a/scripts/libmakepkg/buildenv/lto.sh.in b/scripts/libmakepkg/buildenv/lto.sh.in
+index 6e500eab..6492def7 100644
+--- a/scripts/libmakepkg/buildenv/lto.sh.in
++++ b/scripts/libmakepkg/buildenv/lto.sh.in
+@@ -31,8 +31,8 @@ buildenv_functions+=('buildenv_lto')
+
+ buildenv_lto() {
+ if check_option "lto" "y" && ! check_option "buildflags" "n"; then
+- CFLAGS+=" -flto"
+- CXXFLAGS+=" -flto"
+- LDFLAGS+=" -flto"
++ CFLAGS+=" ${LTOFLAGS:--flto}"
++ CXXFLAGS+=" ${LTOFLAGS:--flto}"
++ LDFLAGS+=" ${LTOFLAGS:--flto}"
+ fi
+ }
+diff --git a/scripts/libmakepkg/lint_config/variable.sh.in b/scripts/libmakepkg/lint_config/variable.sh.in
+index 8327b0a5..03a67ee2 100644
+--- a/scripts/libmakepkg/lint_config/variable.sh.in
++++ b/scripts/libmakepkg/lint_config/variable.sh.in
+@@ -32,10 +32,10 @@ lint_config_variables() {
+ local array=(DLAGENTS VCSCLIENTS BUILDENV OPTIONS INTEGRITY_CHECK MAN_DIRS
+ DOC_DIRS PURGE_TARGETS COMPRESSGZ COMPRESSBZ2 COMPRESSXZ
+ COMPRESSLRZ COMPRESSLZO COMPRESSZ)
+- local string=(CARCH CHOST CPPFLAGS CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS DEBUG_CFLAGS
+- DEBUG_CXXFLAGS DEBUG_RUSTFLAGS DISTCC_HOSTS BUILDDIR STRIP_BINARIES
+- STRIP_SHARED STRIP_STATIC PKGDEST SRCDEST SRCPKGDEST LOGDEST PACKAGER
+- GPGKEY PKGEXT SRCEXT)
++ local string=(CARCH CHOST CPPFLAGS CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS LTOFLAGS
++ DEBUG_CFLAGS DEBUG_CXXFLAGS DEBUG_RUSTFLAGS DISTCC_HOSTS BUILDDIR
++ STRIP_BINARIES STRIP_SHARED STRIP_STATIC PKGDEST SRCDEST SRCPKGDEST
++ LOGDEST PACKAGER GPGKEY PKGEXT SRCEXT)
+
+ local i keys ret=0
+
diff --git a/makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch b/makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch
new file mode 100644
index 000000000000..ca667d88f29d
--- /dev/null
+++ b/makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch
@@ -0,0 +1,40 @@
+From e37f7d8b6b4d2f9accf97eb96d0eacbddf2a1345 Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sat, 1 Jan 2022 14:40:24 +0100
+Subject: [PATCH] makepkg: use -ffile-prefix-map instead of -fdebug-prefix-map
+
+>From gcc(1):
+
+-ffile-prefix-map=old=new
+ [...] Specifying this option is equivalent to specifying all the
+ individual -f*-prefix-map options. This can be used to make reproducible
+ builds that are location independent.
+
+Specifically, this additionally enables -fmacro-prefix-map=, which causes
+prefix mapping to be applied to expansions of __FILE__ and similar macros.
+
+Without this option, if source files are compiled by passing the
+absolute file path to the compiler (as done by e.g. cmake), any
+expansions of __FILE__ (e.g. from uses of assert()) will contain
+$srcdir.
+
+Signed-off-by: Allan McRae <allan@archlinux.org>
+---
+ scripts/libmakepkg/buildenv/debugflags.sh.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/scripts/libmakepkg/buildenv/debugflags.sh.in b/scripts/libmakepkg/buildenv/debugflags.sh.in
+index e0a1ed00..84ca7b71 100644
+--- a/scripts/libmakepkg/buildenv/debugflags.sh.in
++++ b/scripts/libmakepkg/buildenv/debugflags.sh.in
+@@ -30,8 +30,8 @@ buildenv_functions+=('buildenv_debugflags')
+
+ buildenv_debugflags() {
+ if check_option "debug" "y"; then
+- DEBUG_CFLAGS+=" -fdebug-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
+- DEBUG_CXXFLAGS+=" -fdebug-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
++ DEBUG_CFLAGS+=" -ffile-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
++ DEBUG_CXXFLAGS+=" -ffile-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
+ DEBUG_RUSTFLAGS+=" --remap-path-prefix=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
+ CFLAGS+=" $DEBUG_CFLAGS"
+ CXXFLAGS+=" $DEBUG_CXXFLAGS"
diff --git a/makepkg.conf b/makepkg.conf
index 14698a7e00d7..f270d8edc6a4 100644
--- a/makepkg.conf
+++ b/makepkg.conf
@@ -9,10 +9,10 @@
#
#-- The download utilities that makepkg should use to acquire sources
# Format: 'protocol::agent'
-DLAGENTS=('file::/usr/bin/curl -gqC - -o %o %u'
- 'ftp::/usr/bin/curl -gqfC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
- 'http::/usr/bin/curl -gqb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
- 'https::/usr/bin/curl -gqb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
+DLAGENTS=('file::/usr/bin/curl -qgC - -o %o %u'
+ 'ftp::/usr/bin/curl -qgfC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
+ 'http::/usr/bin/curl -qgb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'https::/usr/bin/curl -qgb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
'rsync::/usr/bin/rsync --no-motd -z %u %o'
'scp::/usr/bin/scp -C %u %o')
@@ -33,22 +33,23 @@ VCSCLIENTS=('bzr::bzr'
# ARCHITECTURE, COMPILE FLAGS
#########################################################################
#
-CARCH="@CARCH@"
-CHOST="@CHOST@"
+CARCH="x86_64"
+CHOST="x86_64-pc-linux-gnu"
#-- Compiler and Linker Flags
#CPPFLAGS=""
-CFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fno-plt -fexceptions \
+CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
-Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
-fstack-clash-protection -fcf-protection"
CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
+LTOFLAGS="-flto=auto"
#RUSTFLAGS="-C opt-level=2"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
#-- Debugging flags
-DEBUG_CFLAGS="-g -fvar-tracking-assignments"
-DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
+DEBUG_CFLAGS="-g"
+DEBUG_CXXFLAGS="$DEBUG_CFLAGS"
#DEBUG_RUSTFLAGS="-C debuginfo=2"
#########################################################################
@@ -93,7 +94,7 @@ BUILDENV=(!distcc color !ccache check !sign)
#
OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !debug !lto)
-#-- File integrity checks to use. Valid: ck, md5, sha1, sha224, sha256, sha384, sha512, b2
+#-- File integrity checks to use. Valid: md5, sha1, sha224, sha256, sha384, sha512, b2
INTEGRITY_CHECK=(sha256)
#-- Options to be used when stripping binaries. See `man strip' for details.
STRIP_BINARIES="--strip-all"
@@ -155,4 +156,4 @@ SRCEXT='.src.tar.gz'
#########################################################################
#
#-- Command used to run pacman as root, instead of trying sudo and su
-PACMAN_AUTH=()
+#PACMAN_AUTH=()
diff --git a/pacman.conf.x86_64 b/pacman.conf
index ef39bf8b6148..3982bbec8877 100644
--- a/pacman.conf.x86_64
+++ b/pacman.conf
@@ -15,7 +15,7 @@
#LogFile = /var/log/pacman.log
#GPGDir = /etc/pacman.d/gnupg/
#HookDir = /etc/pacman.d/hooks/
-HoldPkg = pacman-git glibc
+HoldPkg = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
diff --git a/pacman.conf.arm b/pacman.conf.arm
deleted file mode 100644
index 536606173401..000000000000
--- a/pacman.conf.arm
+++ /dev/null
@@ -1,91 +0,0 @@
-#
-# /etc/pacman.conf
-#
-# See the pacman.conf(5) manpage for option and repository directives
-
-#
-# GENERAL OPTIONS
-#
-[options]
-# The following paths are commented out with their default values listed.
-# If you wish to use different paths, uncomment and update the paths.
-#RootDir = /
-#DBPath = /var/lib/pacman/
-#CacheDir = /var/cache/pacman/pkg/
-#LogFile = /var/log/pacman.log
-#GPGDir = /etc/pacman.d/gnupg/
-#HookDir = /etc/pacman.d/hooks/
-HoldPkg = pacman-git glibc
-#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
-#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
-#CleanMethod = KeepInstalled
-Architecture = @CARCH@
-
-# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
-#IgnorePkg =
-#IgnoreGroup =
-
-#NoUpgrade =
-#NoExtract =
-
-# Misc options
-#UseSyslog
-#Color
-#NoProgressBar
-CheckSpace
-#VerbosePkgLists
-#ParallelDownloads = 5
-
-# By default, pacman accepts packages signed by keys that its local keyring
-# trusts (see pacman-key and its man page), as well as unsigned packages.
-SigLevel = Required DatabaseOptional
-LocalFileSigLevel = Optional
-#RemoteFileSigLevel = Required
-
-# NOTE: You must run `pacman-key --init` before first using pacman; the local
-# keyring can then be populated with the keys of all official Arch Linux
-# packagers with `pacman-key --populate archlinux`.
-
-#
-# REPOSITORIES
-# - can be defined here or included from another file
-# - pacman will search repositories in the order defined here
-# - local/custom mirrors can be added here or in separate files
-# - repositories listed first will take precedence when packages
-# have identical names, regardless of version number
-# - URLs will have $repo replaced by the name of the current repo
-# - URLs will have $arch replaced by the name of the architecture
-#
-# Repository entries are of the format:
-# [repo-name]
-# Server = ServerName
-# Include = IncludePath
-#
-# The header [repo-name] is crucial - it must be present and
-# uncommented to enable the repo.
-#
-
-# The testing repositories are disabled by default. To enable, uncomment the
-# repo name header and Include lines. You can add preferred servers immediately
-# after the header, and they will be used before the default mirrors.
-
-[core]
-Include = /etc/pacman.d/mirrorlist
-
-[extra]
-Include = /etc/pacman.d/mirrorlist
-
-[community]
-Include = /etc/pacman.d/mirrorlist
-
-[alarm]
-Include = /etc/pacman.d/mirrorlist
-
-[aur]
-Include = /etc/pacman.d/mirrorlist
-
-# An example of a custom package repository. See the pacman manpage for
-# tips on creating your own repositories.
-#[custom]
-#SigLevel = Optional TrustAll
-#Server = file:///home/custompkgs
diff --git a/pacman.conf.i686 b/pacman.conf.i686
deleted file mode 100644
index f527fc744c4d..000000000000
--- a/pacman.conf.i686
+++ /dev/null
@@ -1,91 +0,0 @@
-#
-# /etc/pacman.conf
-#
-# See the pacman.conf(5) manpage for option and repository directives
-
-#
-# GENERAL OPTIONS
-#
-[options]
-# The following paths are commented out with their default values listed.
-# If you wish to use different paths, uncomment and update the paths.
-#RootDir = /
-#DBPath = /var/lib/pacman/
-#CacheDir = /var/cache/pacman/pkg/
-#LogFile = /var/log/pacman.log
-#GPGDir = /etc/pacman.d/gnupg/
-#HookDir = /etc/pacman.d/hooks/
-HoldPkg = pacman-git glibc
-#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
-#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
-#CleanMethod = KeepInstalled
-Architecture = auto
-
-# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
-#IgnorePkg =
-#IgnoreGroup =
-
-#NoUpgrade =
-#NoExtract =
-
-# Misc options
-#UseSyslog
-#Color
-#NoProgressBar
-CheckSpace
-#VerbosePkgLists
-#ParallelDownloads = 5
-
-# By default, pacman accepts packages signed by keys that its local keyring
-# trusts (see pacman-key and its man page), as well as unsigned packages.
-SigLevel = Required DatabaseOptional
-LocalFileSigLevel = Optional
-#RemoteFileSigLevel = Required
-
-# NOTE: You must run `pacman-key --init` before first using pacman; the local
-# keyring can then be populated with the keys of all official Arch Linux
-# packagers with `pacman-key --populate archlinux`.
-
-#
-# REPOSITORIES
-# - can be defined here or included from another file
-# - pacman will search repositories in the order defined here
-# - local/custom mirrors can be added here or in separate files
-# - repositories listed first will take precedence when packages
-# have identical names, regardless of version number
-# - URLs will have $repo replaced by the name of the current repo
-# - URLs will have $arch replaced by the name of the architecture
-#
-# Repository entries are of the format:
-# [repo-name]
-# Server = ServerName
-# Include = IncludePath
-#
-# The header [repo-name] is crucial - it must be present and
-# uncommented to enable the repo.
-#
-
-# The testing repositories are disabled by default. To enable, uncomment the
-# repo name header and Include lines. You can add preferred servers immediately
-# after the header, and they will be used before the default mirrors.
-
-#[testing]
-#Include = /etc/pacman.d/mirrorlist
-
-[core]
-Include = /etc/pacman.d/mirrorlist
-
-[extra]
-Include = /etc/pacman.d/mirrorlist
-
-#[community-testing]
-#Include = /etc/pacman.d/mirrorlist
-
-[community]
-Include = /etc/pacman.d/mirrorlist
-
-# An example of a custom package repository. See the pacman manpage for
-# tips on creating your own repositories.
-#[custom]
-#SigLevel = Optional TrustAll
-#Server = file:///home/custompkgs