summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--mozconfig.in5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bffbbab6589d..e4c44c333357 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = palemoon
pkgdesc = Open source web browser based on Firefox focusing on efficiency.
pkgver = 27.4.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.palemoon.org/
arch = i686
arch = x86_64
@@ -31,7 +31,7 @@ pkgbase = palemoon
source = git+https://github.com/MoonchildProductions/Pale-Moon#tag=27.4.2_Release
source = mozconfig.in
md5sums = SKIP
- md5sums = 033551ecd40cc00580ed77fa00f31559
+ md5sums = 3b1d2eff90892a99ff6a0e078b35a839
pkgname = palemoon
diff --git a/PKGBUILD b/PKGBUILD
index 34757071de44..9fa74e6860dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: American_Jesus
pkgname=palemoon
pkgver=27.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
url="http://www.palemoon.org/"
@@ -20,10 +20,11 @@ optdepends=('libpulse: PulseAudio audio driver'
source=(git+"https://github.com/MoonchildProductions/Pale-Moon#tag=${pkgver}_Release"
mozconfig.in)
md5sums=('SKIP'
- '033551ecd40cc00580ed77fa00f31559')
+ '3b1d2eff90892a99ff6a0e078b35a839')
prepare() {
sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
+ sed -i 's#xlocale#locale#' Pale-Moon/intl/icu/source/i18n/digitlst.cpp
}
build() {
diff --git a/mozconfig.in b/mozconfig.in
index 5d276cb70426..f8b67e2e234d 100644
--- a/mozconfig.in
+++ b/mozconfig.in
@@ -27,8 +27,9 @@ export CXX=g++-5
# Use python2
mk_add_options PYTHON=/usr/bin/python2
-# use multiple job threads to speed up compilation
-mk_add_options MOZ_MAKE_FLAGS="-j4"
+# uncomment the following to limit the number of parallel build jobs
+# remember to run updpkgsums after, or you'll get a checksum failure
+#mk_add_options MOZ_MAKE_FLAGS="-j4"
# disable junk
ac_add_options --disable-codesighs