summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--glibc2.36-fix.patch20
3 files changed, 34 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dd888c67787..adb5292b637a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = palemoon
pkgdesc = Open source web browser based on Firefox focusing on efficiency.
- pkgver = 31.1.1
+ pkgver = 31.2.0.1
pkgrel = 1
epoch = 1
url = https://www.palemoon.org/
@@ -25,16 +25,19 @@ pkgbase = palemoon
depends = startup-notification
optdepends = libpulse: PulseAudio audio driver
optdepends = ffmpeg: various video and audio support
- source = git+https://repo.palemoon.org/MoonchildProductions/Pale-Moon?signed#commit=ffd78091d8
+ source = git+https://repo.palemoon.org/MoonchildProductions/Pale-Moon?signed#commit=a70dc0b10c
source = git+https://repo.palemoon.org/MoonchildProductions/UXP
source = mozconfig.in
+ source = glibc2.36-fix.patch
validpgpkeys = 3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC
validpgpkeys = 3059E09144F56804F0FBF4E126B40624BDBFD9F3
sha1sums = SKIP
sha1sums = SKIP
sha1sums = 6afaa85faa54ff26be6852009871cb60aea418d7
+ sha1sums = 21f9ef1825cd26928e23bd95ceac2b23ce9bfa2b
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 3617fc2a6dd369fff1f7fa6349abf295a0a9350bdd82f3544bbc6abd60f48009
+ sha256sums = e938be99b0f08ca4778ad032c40baa73077ba2cb47f1dc95200fce7946fe04e7
pkgname = palemoon
diff --git a/PKGBUILD b/PKGBUILD
index ce3b492e30de..03cf273844fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=palemoon
_repo=Pale-Moon
epoch=1
-pkgver=31.1.1
+pkgver=31.2.0.1
# Commit ID can be found at https://repo.palemoon.org/MoonchildProductions/Pale-Moon/releases
-_commit=ffd78091d8
+_commit=a70dc0b10c
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -21,15 +21,18 @@ optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
source=(git+"https://repo.palemoon.org/MoonchildProductions/${_repo}?signed#commit=${_commit}"
git+"https://repo.palemoon.org/MoonchildProductions/UXP"
- mozconfig.in)
+ mozconfig.in
+ glibc2.36-fix.patch)
validpgpkeys=('3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC'
'3059E09144F56804F0FBF4E126B40624BDBFD9F3')
sha1sums=('SKIP'
'SKIP'
- '6afaa85faa54ff26be6852009871cb60aea418d7')
+ '6afaa85faa54ff26be6852009871cb60aea418d7'
+ '21f9ef1825cd26928e23bd95ceac2b23ce9bfa2b')
sha256sums=('SKIP'
'SKIP'
- '3617fc2a6dd369fff1f7fa6349abf295a0a9350bdd82f3544bbc6abd60f48009')
+ '3617fc2a6dd369fff1f7fa6349abf295a0a9350bdd82f3544bbc6abd60f48009'
+ 'e938be99b0f08ca4778ad032c40baa73077ba2cb47f1dc95200fce7946fe04e7')
prepare() {
sed 's#%SRCDIR%#'"${srcdir}"'#g' mozconfig.in > mozconfig
@@ -37,6 +40,7 @@ prepare() {
git submodule init
git config submodule.platform.url "${srcdir}/UXP"
git submodule update
+ patch -Np1 -i "${srcdir}/glibc2.36-fix.patch"
}
build() {
diff --git a/glibc2.36-fix.patch b/glibc2.36-fix.patch
new file mode 100644
index 000000000000..5cb17d153727
--- /dev/null
+++ b/glibc2.36-fix.patch
@@ -0,0 +1,20 @@
+https://forum.palemoon.org/viewtopic.php?f=62&t=28676
+diff -aur a/platform/ipc/chromium/src/third_party/libevent/arc4random.c b/platform/ipc/chromium/src/third_party/libevent/arc4random.c
+--- a/platform/ipc/chromium/src/third_party/libevent/arc4random.c 2022-08-03 10:28:29.353126800 +0100
++++ b/platform/ipc/chromium/src/third_party/libevent/arc4random.c 2022-08-03 21:16:14.795881259 +0100
+@@ -482,6 +482,7 @@
+ #endif
+
+ #if defined(_we_have_arc4random_buf) || !defined(XP_SOLARIS)
++#if (__GLIBC__ <= 2 && __GLIBC_MINOR__ < 36) || !defined(XP_LINUX)
+ ARC4RANDOM_EXPORT void
+ arc4random_buf(void *_buf, size_t n)
+ {
+@@ -496,6 +497,7 @@
+ _ARC4_UNLOCK();
+ }
+ #endif
++#endif
+
+ #ifndef ARC4RANDOM_NOUNIFORM
+ /*